Jump to content

Folder Rename


prab007
 Share

Recommended Posts

Hello There,

As per the cubecart security suite I renamed the admin folder as well as the admin directory. Everything was running fine until i got this message:

Not Acceptable

An appropriate representation of the requested resource /98510a.php could not be found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

The only thing I was trying to do is to save my work.

Every time I go to Store Settings and try to save my work I get this message please help!!!!

I tried renaming it back to admin but cubecart wont work then.

 

Is there any other place I need to rename as well. Your help is much appreciated.

 

Regards,

@Dirty Butter @bsmither @Al Brookbanks please help urgently!!!

Link to comment
Share on other sites

Everything worked fine for me once I used my head and fixed my bookmark. Perhaps you should check your phpMyAdmin table and be sure the new table has your info correctly saved. Do you use a prefix? Sometimes that can cause plugin issues.

Hmmmm - took a look at the tables for the first time just now, and it doesn't look like anything but my IP address is in the tables - rest of the entries must be for people who subscribe.

Edited by Dirty Butter
Link to comment
Share on other sites

Renaming the /admin.php file to /98510a.php should not really be a problem.

The "406: appropriate representation" error may be a 'red herring' in that there may be mod_security rules in place that will catch POST values that contain certain sequences of new lines. It could be CRLFCRLF (two line endings in Windows format), CRCR (two line endings in Mac format, or LFLF (two line endings in Unix format), or something else. The Store Setting's Address text field is one place where multiple lines can be entered.

The rules could also be hitting on URLs in the content stream for POSTed values. If CubeCart will accept them, just do not add http::// to any data field that asks for a URL.

Please consult your hosting provider who may have a log of mod_security "hits" against your site.

Until they respond, you might try adding the following to your .htaccess file:

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...