Jump to content

Login as admin fail - Error message "The includes/global.inc.php file has no value for the 'encoder' parameter. This needs to be set to 'zend' or 'ioncube'."


ultimate R. S.
 Share

Recommended Posts

Dear all,

On Year 2010, I've installed Cubcart-online-Shop for one of my customer. Now the administrator cannot log in his shop. Error occured with

"The includes/global.inc.php file has no value for the 'encoder' parameter. This needs to be set to 'zend' or 'ioncube'."
Can someone say to me, what can be the issue of this failure?

Thx in advance

ultimate R. S.

Link to comment
Share on other sites

Welcome ultimate R. S.! Glad to see you made it to the forums.

Please determine the version of CubeCart you have installed (examine the file /ini.inc.php).

For the same major version, please download the latest minor version from CubeCart's download site.

The latest minor versions have removed the need for, and the checks for, licensure (encoding).

If you do not want to upgrade to the latest minor version's complete codebase, at least replace just the index.php and admin.php files.

I cannot say how, suddenly, the /includes/global.inc.php file is now missing a value for the ['encoder'] setting.

Link to comment
Share on other sites

  • 4 months later...

I have the same issue: After editing ini.php and adding  

disable_functions =exec,passthru,shell_exec,system,proc_open,popen,curl_exec,curl_multi_exec,parse_ini_file,show_source,pcntl_exec  for security and

editing global.inc.php to change the admin folder and file name

$glob['adminFile'] = 'admin.php';
$glob['adminFolder'] = 'admin';

I am unable to login to admin as the old /admin or the changed admin name. I then returned the global.inc.php

back to the above initial/original and am still unable to login with shop/admin or shop/admin.php and unable to turn bold text off. php.ini remains with the above changes.

 

The error log for 

[Wed Dec 23 23:39:09 2015] CURRENT SERVER TIME
MAIN error_log:
[Wed Dec 23 23:39:01 2015] [error] [client 74.220.215.221] 
[Wed Dec 23 23:39:01 2015] [error] [client 74.220.215.221] Zend Optimizer requires Zend Engine API version 220060519.
[Wed Dec 23 23:39:01 2015] [error] [client 74.220.215.221] The Zend Engine API version 220131226 which is installed, is newer.
[Wed Dec 23 23:39:01 2015] [error] [client 74.220.215.221] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.
[Wed Dec 23 23:39:01 2015] [error] [client 74.220.215.221] 
[Wed Dec 23 23:39:02 2015] [error] [client 74.220.215.221] Premature end of script headers: index.php
[Wed Dec 23 23:39:02 2015] [error] [client 74.220.215.221] Premature end of script headers: index.php
[Wed Dec 23 23:39:03 2015] [error] [client 104.217.216.173] Premature end of script headers: index.php
[Wed Dec 23 23:39:03 2015] [error] [client 104.217.216.173] Zend Guard Loader requires Zend Engine API version 220100525.
[Wed Dec 23 23:39:03 2015] [error] [client 104.217.216.173] The Zend Engine API version 220131226 which is installed, is newer.
[Wed Dec 23 23:39:03 2015] [error] [client 104.217.216.173] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Guard Loader.
[Wed Dec 23 23:39:03 2015] [error] [client 104.217.216.173] 
[Wed Dec 23 23:39:04 2015] [error] [client 104.217.216.173] Premature end of script headers: 500.php
[Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] Failed loading /usr/php/54/usr/lib64/php/modules/ioncube_loader_lin.so:  /usr/php/54/usr/lib64/php/modules/ioncube_loader_lin.so: undefined symbol: execute
[Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] SourceGuardian requires Zend Engine API version 220100525.
[Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] The Zend Engine API version 220131226 which is installed, is newer.
[Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] Contact SourceGuardian Ltd. at http://www.sourceguardian.com/ for a later version of SourceGuardian.
[Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] 
[Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] Zend Guard Loader requires Zend Engine API version 220100525.
[Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] The Zend Engine API version 220131226 which is installed, is newer.
[Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Guard Loader.
[Wed Dec 23 23:39:05 2015] [error] [client 104.217.216.173] 
[Wed Dec 23 23:39:05 2015] [error] [client 66.249.69.112] Failed loading /usr/lib64/php/modules/ioncube_loader_lin.so:  /usr/lib64/php/modules/ioncube_loader_lin.so: undefined symbol: execute
[Wed Dec 23 23:39:05 2015] [error] [client 66.249.69.112] Zend Optimizer requires Zend Engine API version 220060519.
[Wed Dec 23 23:39:05 2015] [error] [client 66.249.69.112] The Zend Engine API version 220131226 which is installed, is newer.
[Wed Dec 23 23:39:05 2015] [error] [client 66.249.69.112] Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Optimizer.
[Wed Dec 23 23:39:05 2015] [error] [client 66.249.69.112] 
[Wed Dec 23 23:39:06 2015] [error] [client 66.249.69.112] Premature end of script headers: index.php
[Wed Dec 23 23:39:06 2015] [error] [client 66.249.69.112] Failed loading /usr/lib64/php/modules/ioncube_loader_lin.so:  /usr/lib64/php/modules/ioncube_loader_lin.so: undefined symbol: execute

 

Any suggestions on this before we all get merry? Ho ho ho!  Best wishes to all those who have been a great source of info and assistance. May you have a good time with friends and family over the holiday period.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...