Jump to content

what did I do?


kinchi
 Share

Recommended Posts

hello,

I have been tweaking my cubecart and I noticed the URL looks different then it did, its no longer purging the URL, its now ends in .html

This has me scratching my head, Im thinking maybe the .htaccess file got changed or something happened when I was in my cpanel, I set some directly listing rules and that might explain why its changed but I don't see anything wrong with it

it use to say something like http://kinchi.ca/index.php?=pendants

but now its showing .html extentions in the URL like its in a folder but there is no folder called /pendants ?

http://kinchi.ca/pendents/kinchi-lockets.html 

has anyone seen this happen before? Im not experienced with this but I know somethings changed and I cant seem to figure what I did

anyone know what I did?  maybe  someone can post the default .htaccess file cor CC6 maybe mine was modified by my cpanel and changed it.

Thanks,

 

 

Link to comment
Share on other sites

CubeCart 6 insists on using "search-engine-friendly" URLs.

Where, in CC5, this was optional, but the standard URL for CC5:
www.example.com/index.php?_a=product&product_id=1

And the SEO-style URL:
www.example.com/automotive/steering-wheel-covers/real-mink.html

CC6 insists on the SEO style.

If you are running CC5, you may have enabled the SEO mode on the Store Settings, Search Engines tab.

Link to comment
Share on other sites

hi bsmither, thanks again for your help ,  but I not sure I understand your answer,

I could be wrong but it I think this started happening after I was cleaning up some log files & made changed some directory privacy settings (for an unrelated folder) in my cPanel is when I noticed the change to the url's

Here's an example of what I mean:

I see my browser history has the following entry from yesterday (since I installed CC6)

http://kinchi.ca/index.php?_a=certificates

that link above works fine, and is the right format but now links are generated in the format like

http://kinchi.ca/gift-certificates.html

I looked at the search engine settings and it was set to

Add Category to URL: NO
Add Product to URL:  NO
 Meta Data Behavior: Disabled 
 

how do I get it back to using this format URL (or disable Search Engine Friendly)  

http://kinchi.ca/index.php?_a=certificates  

 

thanks again:)
Robert

 

 

 

Link to comment
Share on other sites

I see that the skin being used is Foundation, so I assume you are now running CubeCart v6.

In CC6, the _a=certificates will certainly work forever, but over time, as you visit pages, your browser will increasingly use the newer /gift-certificates.html style of URL.

In CC6, you cannot get away from this newer style.

 

Link to comment
Share on other sites

CubeCart, Ltd. would reply that running CubeCart on any web server other than Apache is "unsupported", and rightly so, as CubeCart, Ltd. wouldn't want to be needing to be familiar with several, if not dozens, of web servers and how they get configured for URL rewriting.

But, for those who choose to not run Apache (really, why would anyone choose to not run Apache, or be hosted by any company that does not run Apache???), or that one other web server that can read .htaccess files, it becomes then that person's responsibility to figure out how to get URL rewriting implemented.

Until that happens, mandatory URL rewriting is a full stop obstacle to experimenting/developing with CC6.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...