Jump to content

[Resolved] Access Denied For User...


toast691
 Share

Recommended Posts

Hi,

I have been trying to live link my sql database to Microsoft excel and in the process of that I changed the password for the user "greenpat_cube806" which created the following error:


Warning: mysqli::mysqli() [mysqli.mysqli]: (28000/1045): Access denied for user 'greenpat_cube806'@'localhost' (using password: YES) in /home/greenpatchseeds/public_html/classes/db/mysqli.class.php on line 30

Warning: mysqli_options() [function.mysqli-options]: Couldn't fetch mysqli in /home/greenpatchseeds/public_html/classes/db/mysqli.class.php on line 32

Fatal error: Access denied for user 'greenpat_cube806'@'localhost' (using password: YES) in /home/greenpatchseeds/public_html/classes/db/mysqli.class.php on line 35

 

I have since changed the password back to the original and allowed all privileges for user greenpat_cube806 in the "MySQL Account Maintenance" area. The issue does not seem to be resolved. I am using the latest version of CC.

Any ideas?

Regards

Stami

Link to comment
Share on other sites

Did the MySQL server happen to receive a change to the source of the connection for greenpat_cube806?

That is to say, a MySQL server, when constructing a user, can also hold where that user may connect from:
[email protected] <= from same server
[email protected]* <= from same local net
[email protected] <= from specific server
[email protected]* <= from anywhere

I do not know what screen you would ask to view to determine the user's connection source in the "MySQL Account Maintenance Area".

Link to comment
Share on other sites

Hi Brian,

Thanks for the reply.

In the MySQL maintenance area I can't find where it would show that either and there is no options when creating a new user to select the source of connection so I am presuming it auto assigns to @localhost. In phpmyadmin all mentions are of @localhost.

Link to comment
Share on other sites

I was asking because I am fairly certain that your experiments with Excel would have 100% failed because, as any user created to access the database (you could have created another user for your Excel experiments) would (apparently) default to being restricted to a localhost connection.

So, if phpMyAdmin can access the database from your cPanel (or whatever hosting account control panel you have) using @localhost, then your CubeCart application - hopefully being on the same server - can also access the database using 'localhost' as the ['hostname'] in the /includes/global.inc.php file.

Just double-check that the user that can access the CubeCart database in in your control panel is spelled the same, and has the same password, as in globals.inc.php. Make sure to note capital-eye (I) vs lowercase-el (l).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...