Jump to content

[Resolved] Yikes! I've broken something and locked myself out of admin


BooJewels
 Share

Recommended Posts

Good morning.  I've seemingly done something stupid and locked myself out of the admin panel of my old, but public and active, CC3 store.

I'm just upgrading to CC6 (well, Al's doing it for me) and working on a cloned site which is just about ready to go live on Monday.  I bought an SSL and my host installed this yesterday and it appears to be working.  I could see that the padlock appeared in the new CC6 site and when going to the basket/checkout it changed to https: 

I wondered if the old CC3 store did this too.  So I added something in the basket and went to view basket and it told me it was an insecure site and to return.  I realised I hadn't told it to enable SSL in the settings, so I went and did this and when now trying to view the basket, I got my custom 404 page.  So I decided something obviously wasn't set right and I'd speak to my host, so went to put it back to 'no' in 'enable SSL' and as I clicked the no (didn't even get to update the settings), I got a blank white page that eventually loaded as my 404 page without it's style or images.

I just can't get back in to the admin page, I've tried typing the URL manually, using bookmarks and different browsers and get the same broken 404 - no log in screen or admin page.

On the public pages, the site appears to be working okay, but you add something to the basket and then try and view it, you get a 404 page - obviously rendering my site un-working until I can fix it.

Is there anything I can change in cPanel or the like to restore it.  I'll ask my host the same question as they've set up the SSL, but I'm livid with myself for seemingly breaking it in one click - although, in my defence, the site itself wasn't actually working before I started messing - it was just broken differently.

I think the original problem with the checkout looking insecure is a setting issue for the host, but me changing it to not finding the basket and locking myself out of admin is my fault.

I have two domains in the hosting that I use interchangeably - the creations version is the 'master' if you like.

 CC3 version:  http://www.boo-creations.co.uk/shop/index.php

CC3 alternative domain:   http://www.boo-jewellery.co.uk/shop/index.php  

Cloned CC6 upgrade of new site:  http://www.boo-creations.co.uk/staging/

Alternative domain CC6:  http://www.boo-jewellery.co.uk/staging/

Link to comment
Share on other sites

Panic over. 

I sent much the same message to my host and whilst they came back and said they hadn't done anything, as it was already correct, it suddenly corrected itself and all the assorted problems I'd had vanished.  The CC3 store now directs to the basket when there's something in it and doesn't give security warnings.  On i.e I couldn't get to the basket as it said the site was insecure and to return, but that suddenly works now.  They reckon it was a cache issue, but I didn't clear my cache, it just worked properly when I opened the browser and tried again.

My log-in page for CC3 admin came back after getting a 404 on everything I tried.  I know I didn't do anything, as I walked away from the computer and was elsewhere.

I would have just deleted the thread, but I don't think I can.  So apologies for the panic-stricken intrusion earlier.  I could have done without it this morning too.   :D

Link to comment
Share on other sites

Thank you.  I'm mighty relieved, it's already been a pretty horrible week.

I must admit, when I did a search for similar problems, I did see your thread about not having admin access for days with a poor host, so you'll know that sick feeling of panic I felt when I couldn't get my admin log-in page to even show.

As you say, I'd rather know what went wrong so that I can potentially fix it if it happens again - or preferably, avoid breaking it in the first instance.  But I'm pretty sure it was a setting of the SSL certificate being applied, because security warnings on the other version of the site don't change because I maybe corrupted a file elsewhere.   And they swear they didn't do anything, but it suddenly all got fixed.  In their defence, I got a message within minutes saying they'd look into it for me and it was 'fixed' just over an hour later, so at least they were attentive - on a Saturday!

It frightens me a little that in order to sell on-line, we need to learn all this stuff and I find it all a little daunting, as much of it is beyond me, so I learn as I go.  It's when it breaks you fully appreciate how little you know and how out of your depth you are - and how dangerous a little bit of knowledge is!

Al Brookbanks has been a star this week helping me through it all, bless him.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...