Jump to content

Impossible to reset password after upgrade - RESOLVED


sailing123
 Share

Recommended Posts

Hi

Yesterday, I tried to upgrade to the latest version 6.0.12 but the server was running on a lower PHP. My host has now migrated our website to their newest server. I tried to log in again this morning and my login details are not recognised anymore. I decided to reset the password and it does not even recognise my username and email. I am therefore looked out altogether.

How do I go from there ?

Thank you

S.

Link to comment
Share on other sites

well, let me clarify the question, you said that the host "migrated" you to their newest server. This implies that you host picked up your site and moved it to a new server.

did the actually migrate your site to a new server, or did they simply upgrade the PHP version on the existing server?

Is your store front working, or do you see errors?

 

Link to comment
Share on other sites

Hi Noodleman,

My host moved my entire website, the LIVE V 4.4.2, which includes the testing upgrade V6.0.11 under a subfolder to a newer server. It is called a different name.

My mistake regarding password reset, it was a very old email address I should have used, now sorted. However, Cubecart 4.4.2 does not seem to like PHP 5.5, several errors messages on front end:

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/xxxx/public_html/classes/db/db.php on line 45

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/xxxx/public_html/includes/sef_urls.inc.php on line 208
 

and back end:

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/xxxxi/public_html/classes/db/db.php on line 45

Strict Standards: Redefining already defined constructor for class admin_session in /home/xxxx/public_html/classes/session/cc_admin_session.php on line 42

It is going to be a nightmare. I can see they are currently trying to fix it all. If V4.4.2 cannot cope with PHP 5.5, I will have to separate the LIVE and the testing upgrade on two different servers. Am I right ?

Thanks

S.

Link to comment
Share on other sites

Hi

Indeed, the original question was regarding CC6 login but issues arose with the LIVE 4.4.2 as the two are linked being on the same server.

Update: my host has managed to resolve it all expect for one line which I am querying with them but hopefully one of you will know the answer too. I still get the following message on all back end pages of V4.4.2 as well as on printed invoices:

Strict Standards: Redefining already defined constructor for class admin_session in /home/xxxx/public_html/classes/session/cc_admin_session.php on line 42

Technically there is no support for the old Cubecart any longer, I know, but if someone has the knowledge to my 2 questions I would be very grateful:

1. Is that message critical and a worry to be addressed ?

2. How can I remove it so that it does not print on all invoices ?

I still need to run the V4 while the upgrade V6 gets completed, hopefuly before Xmas now ....

Many thanks again.

S.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...