Jump to content

[Resolved] Can't Login to Admin Panel


Recommended Posts

Did a fresh install of the newest version of CubeCart and everything appeared to work; however, I cannot login to the admin area.  I enter the username and password that I set up during installation and when I try it, I don't get an error, just refreshes the login screen.  Has anyone experienced this issue?  I've reinstalled several times and have experienced the same issue each time.  Thanks for the help!

Link to comment
Share on other sites

If you have tried five times (I think) within 10 minutes, then I think you have been locked out.

Either wait for a while, or use an external utility such as phpMyAdmin to access your database directly, and remove all the rows from CubeCart_blocker.

But this doesn't explain why you were initially getting bounced back to the login screen.

Do you, perhaps, have a browser utility that is blocking cookies from your site?


Link to comment
Share on other sites

Thanks for all the suggestions - so far haven't found the solution.  

** To install, I unzipped on my computer and loaded all files via FTP, then followed the setup

** I've tried in several browsers and, so I don't think it is a popup blocker.

** Nothing in the error log

I'll keep trying but welcome any suggestions.  Thanks!

Link to comment
Share on other sites

4 minutes ago, jrjdegroot said:

** To install, I unzipped on my computer and loaded all files via FTP, then followed the setup


I think I've read that the FTP client would not have uploaded the empty folders required for temporary cache type activities. Please try the install again from your cpanel - uploading the zipped file, then extracting it from within your Filemanager on the server, and run setup again.

Link to comment
Share on other sites

What you read was that some ZIP utilities (WinZip, in particular) will not create empty folders. Then, FTP'ing the lot to your site will have two folders that will not be present: /images/cache/ and /images/source/.

If I recall, this presented a problem with getting images uploaded and assigned to the products.

Link to comment
Share on other sites

well, I was just getting ready to upgrade from within my admin, and noticed I had been having some trouble today with pages loading and timing out, or saying they were not working etc, so I decided to come to the forum and see if anyone was having trouble with the new CC upgrade, before I upgraded myself. Sure glad I did.

Any ideas as to when all these issues I have been reading in the forum threads about the new upgrade, will be stable and resolved.

I already have enough issues going on I am trying to resolve, like my email client etc still not working, and certainly don't need anymore.

Link to comment
Share on other sites

Please try this:

In the file /includes/global.inc.php:

Add these statements just above the last line of the file (last line shown below as the last line of the file):

$glob['storeURL'] = '';
$glob['standard_url'] = '';
$glob['ssl_url'] = '';
$glob['cookie_domain'] = '';
$glob['rootRel'] = '/~devsite/'; // Must have trailing slash!


CubeCart may be creating a cookie where the PATH is a malformed URL. In this case, the browser may be objecting to sending the cookie back to the site.

You may also need to manually edit the .htaccess file to have these statements near the top. The first two statements may already be present:

<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteBase /~devsite/ 


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...