Jump to content

[Resolved] Impossible to add an image to a product (cc 6.1.1)


benjAeby
 Share

Recommended Posts

Hello and Happy new year!

I'm a new user of cubecart. Everything worked fine from installation to paiement methods (paypal + print order... only) but I can't put any image to a product!

I already tried to reinstall but the problem remains : loading an image (<500kb) from product/image loads the image, save display the confirmation message, but no image is linked to the product...

 

Thanks for helping me to solve this issue...

Regards

Benjamin

 

Link to comment
Share on other sites

Hi @benjAeby Welcome to the forums.

Once the image is uploaded you have to find the image name in the Product Listing FileManager box on the Images tab. There is a check box to the right that you should double click in to get a star for the first image and click to get check mark for any additional images. This "connects" the images with the correct product.

PS: This is an awkward process in 6.1.1, but will be considerably improved when 6.1.2 is released.

Link to comment
Share on other sites

Hi Dirty Butter,

Thank you for your answer.

Even if I manage to upload photos, the Product Listing FileManager box on the Images tab is still empty.

If I try to update the file list, an error happens : "file list update impossible"

Would you have any idea of what I'm doing wrong? Could the french language pack be an issue?

Thanks

 

 

cc_error.PNG

imagesAreUploaded.PNG

emptyImageList.PNG

Link to comment
Share on other sites

If I try to update the file list, an error happens : "file list update impossible"

The language key for that phrase is filemanager:error_list_update.

The English language pack for that key has the phrase, "No changes were detected." Both phrases are completely misleading. But a language pack cannot cause this kind of trouble.

You say you can get images uploaded, and they get listed in the Image Filemanager listing, but cannot see them in the Add/Edit Product, Images tab filepicker window.

We will need to concentrate our troubleshooting starting there.

Please create the error_log to see if any clues can help.

Link to comment
Share on other sites

For some reason, PHP is getting confused about what folders should be searched in, and in what order, for files to execute.

The current folder (denoted by a period), where CubeCart is running, should be searched first. For some reason , the current folder is not being searched first, or at all.

The folders /usr/share/pear/ and /usr/share/php/ are being searched, and these folders are not allowed to be searched by the restrictions imposed by openbase_dir.

However:

the allowed path(s): (/home/httpd/vhosts/asaeby.ch/:/tmp/) in /home/httpd/vhosts/asaeby.ch/benjaeby.ch/oc/classes/autoloader.class.php

suggests that the allowed path(s):
/home/httpd/vhosts/asaeby.ch/:/tmp/

does not include the current working directory.

I am probably wrong (I don't know much about Linux systems), but maybe the path statement should be:
.:/home/httpd/vhosts/asaeby.ch/:/tmp/

Note the period as the first path in the series of paths (separated by the colon).

Or maybe the list of allowed paths for open_basedir need a different delimiter -- a comma or new line???

Link to comment
Share on other sites

Hi Dirty Butter and bsmither,

I'm using a commercial host with plesk (12.5.30). I have access to open_basedir settings. cubecart is installed on a subdomain (not on the primary domain). I tried several open_basedir settings without success.

I've send the error log to the hosting support...

Regards

 

Link to comment
Share on other sites

Hi all,

My problem is solved now.

That was my fault, and had no link with open_basedir or php settings. The mistake I made was to rename the admin_xxxxx.php file into a more convenient name! Renaming this file as it was at install solved the empty file list problem.

Thank you for your help and for the good job done on cubecart!

Benjamin

Link to comment
Share on other sites

2 minutes ago, benjAeby said:

The mistake I made was to rename the admin_xxxxx.php file into a more convenient name! Renaming this file as it was at install solved the empty file list problem.

You CAN rename the admin folder/file to suit yourself AS LONG AS you make corresponding changes in the global.inc.php file.

Link to comment
Share on other sites

global.inc.php is in the includes folder. (Don't edit the global.inc.php-dist file by accident.) You will have to change the permission on the file in order to be able to edit it. Be sure to change the permission back to 444 when you are finished.

Once you have a naming system that suits you, please be sure in any future posts on the forum that involve showing your code (perhaps error_log entries?) that you XXX out whatever you renamed your admin file/folder.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...