Jump to content

6.1.3 Upgrade SMTP stopped working


Recommended Posts

I placed a test order after upgrading my store and noticed that I didn't receive an admin email. I then tested SMTP and found the following error message.

SERVER -> CLIENT: 220-vps.matrixresurrection.com.au ESMTP Exim 4.87 #1 Fri, 06 Jan 2017 16:18:51 +1100 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.
CLIENT -> SERVER: EHLO thrill.com.au
SERVER -> CLIENT: 250-vps.matrixresurrection.com.au Hello thrill.com.au [103.250.21.101]250-SIZE 52428800250-8BITMIME250-PIPELINING250-AUTH PLAIN LOGIN250-STARTTLS250 HELP
CLIENT -> SERVER: STARTTLS
SERVER -> CLIENT: 220 TLS go ahead
SMTP Error: Could not connect to SMTP host.
CLIENT -> SERVER: QUIT
SERVER -> CLIENT: 221 vps.matrixresurrection.com.au closing connection
SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Link to comment
Share on other sites

When I tested SMTP (using port 25) in the Admin Panel I got the following, which all looks ok to me:

Quote
Testing SMTP with mail server mail.
SERVER -> CLIENT: 220-server54115.havenswift.co.uk ESMTP Exim 4.87 #1 Fri, 06 Jan 2017 19:44:04 +0000 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.
CLIENT -> SERVER: EHLO dev.wymeruk.co.uk
SERVER -> CLIENT: 250-server54115.havenswift.co.uk Hello wymeruk.co.uk [77.92.92.163]250-SIZE 52428800250-8BITMIME250-PIPELINING250-AUTH PLAIN LOGIN250-STARTTLS250 HELP
CLIENT -> SERVER: AUTH LOGIN
::::::::::::::::::
SERVER -> CLIENT: 235 Authentication succeeded
CLIENT -> SERVER: MAIL FROM:<shop@wymeruk.co.uk>
SERVER -> CLIENT: 250 OK
CLIENT -> SERVER: RCPT TO:<shop@wymeruk.co.uk>
SERVER -> CLIENT: 250 Accepted
CLIENT -> SERVER: DATA
SERVER -> CLIENT: 354 Enter message, ending with "." on a line by itself
CLIENT -> SERVER: Date: Fri, 6 Jan 2017 19:44:04 +0000
CLIENT -> SERVER: To: [email protected]
CLIENT -> SERVER: From: Wymer UK Online Store <shop@wymeruk.co.uk>
CLIENT -> SERVER: Subject: Testing SMTP
CLIENT -> SERVER: Message-ID: <[email protected]>
CLIENT -> SERVER: X-Mailer: PHPMailer 5.2.21 (https://github.com/PHPMailer/PHPMailer)
CLIENT -> SERVER: MIME-Version: 1.0
CLIENT -> SERVER: Content-Type: multipart/alternative;
CLIENT -> SERVER: boundary="b1_51100fad5b690c759800e039fae35b0a"
CLIENT -> SERVER: Content-Transfer-Encoding: 8bit
CLIENT -> SERVER:
CLIENT -> SERVER: This is a multi-part message in MIME format.
CLIENT -> SERVER:
CLIENT -> SERVER: --b1_51100fad5b690c759800e039fae35b0a
CLIENT -> SERVER: Content-Type: text/plain; charset=us-ascii
CLIENT -> SERVER:
CLIENT -> SERVER: Testing email sent by "SMTP" from CubeCart v6.1.3 at http://dev.wymeruk.co.uk.If you are reading this message then you can be sure that email from your store is working.
CLIENT -> SERVER:
CLIENT -> SERVER:
CLIENT -> SERVER: --b1_51100fad5b690c759800e039fae35b0a
CLIENT -> SERVER: Content-Type: text/html; charset=us-ascii
CLIENT -> SERVER:
CLIENT -> SERVER: Testing email sent by "SMTP" from CubeCart v6.1.3 at http://dev.wymeruk.co.uk.<br><br>If you are reading this message then you can be sure that email from your store is working.
CLIENT -> SERVER:
CLIENT -> SERVER:
CLIENT -> SERVER:
CLIENT -> SERVER: --b1_51100fad5b690c759800e039fae35b0a--
CLIENT -> SERVER:
CLIENT -> SERVER: .
SERVER -> CLIENT: 250 OK id=1cPaQm-00048d-OR
CLIENT -> SERVER: QUIT
SERVER -> CLIENT: 221 server54115.havenswift.co.uk closing connection

 

 

I also tried changing to use the SSL/TLS settings (port 465), and got the following:

Testing SMTP
SERVER -> CLIENT:
SMTP NOTICE: EOF caught while checking if connected
SMTP Error: Could not authenticate.
SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

 

Link to comment
Share on other sites

2 hours ago, Dirty Butter said:

I've tested with SSL and TLS settings. The TLS popup on test says it failed, BUT I do get the email saying it worked.

I get a similar long popup with SSL that Mike did - mine says authentication was successful, and I receive the test email.

Also on Havenswift.

If it's any help, my Havenswift Control Panel told me to use "mail.wymer.co.uk" as my SMTP Host for port 25, and "wymer.co.uk" (no "mail") for port 465 - which I now know should be 587.

Link to comment
Share on other sites

If you change between using insecure SMTP on port 25 and either SSL on port 465 or TLS on 587 then you will need to change the outgoing mail server so uses the correct one. As Mike mentioned using mail.domain.com works for insecure port 25 but will not work for either of the secure methods where simply domain.com should be used. This isn't something specific to our hosting btw !

NOTE (mainly for non Havenswift customers) : this of course assumes that you have your own SSL installed on your domain (which both of you do) because if you don't you may not be able to send secure SMTP at all or may need to use the server secure outgoing mailserver URL if that is made available to you by your hosting company.

Ian

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...