Jump to content

[Resolved] Updates new admin


Christopher Short
 Share

Recommended Posts

On 2/17/2017 at 4:50 PM, keat said:

Zaromnia

In public_html, change the admin.whateveritis.php to what you want it to be.

Then using ftp open up includes/global.inc.php and change the corresponding line for $glob['adminFile'] = 'your-new-filename.php';

No need to change the admin folder name.

 

As for the GitHub post, suggested by Al, i'd suggest that you could possibly leave this alone for now.

I'd imagine that this will be written in to the next update, so might not be an issue moving forward.

 

On 2/17/2017 at 5:23 PM, Dirty Butter said:

You will need to change the permission on your global.inc.php file to 744 in order to be able to change the naming to what you want (DO NOT GO BACK TO PLAIN ADMIN). After you have saved your file with your naming, change the permission back to 444.

Also, when you have all the naming for the admin_XXX folder and file set to what you want - be sure there is not an additional old folder hanging around named admin or a file named admin.php. (Not everyone is getting these leftover file/folders messes) They need to be deleted ONCE YOU ARE SURE you can login to the Dashboard with YOUR renamed admin_XXX.php.

Thank you, I've managed to get it done, was able to change the admin folder name as well.

Link to comment
Share on other sites

  • 1 month later...

31 minutes ago, Al Brookbanks said:

The release notes for 6.1.6 says that a manual upgrade is required.

The auto upgrade should then work from 6.1.6 upwards.

So on those grounds it's not still an issue.

Yeah, so those notes don't show in the admin section when it prompts for an update...at least mine didn't. Now I know. Will a manual update now fix it?

Link to comment
Share on other sites

Not being the same is fine, as long as it matches. So THAT's not the problem.

I just set my test site up to upgrade manually. MY url is https: //dirtybutter.com/testsiteXXX/setup/ (I left a blank to keep the url showing for you)

I did NOT do this from within CC - just put the store url with /setup at the end.

Yours would be csrocketry.com/setup

 

Link to comment
Share on other sites

26 minutes ago, Dirty Butter said:

Not being the same is fine, as long as it matches. So THAT's not the problem.

I just set my test site up to upgrade manually. MY url is https: //dirtybutter.com/testsiteXXX/setup/ (I left a blank to keep the url showing for you)

I did NOT do this from within CC - just put the store url with /setup at the end.

Yours would be csrocketry.com/setup

 

yep. it forwards to the other link and shows a 404 error. Now, I had already done this from admin before anyone pointed out the manual requirement to stop the link changing. I reloaded the files manually.

Link to comment
Share on other sites

It may be that you have something maybe in the wordpress part that is redirecting in some odd way. Try seeing if you can see a test file at the store root level at this point from csrocketry.com. If it 404's then it's some kind of redirect issue.

That's all I can think of. If that's not the issue, it's time for you to get much more knowledgeable help than I can provide. @bsmitheris busy right now and not on very much, so maybe  @bsandall or @havenswift-hosting will be able to spot how to fix this. Of course you can always pay for a month's support from CC and let them fix it for you.

Link to comment
Share on other sites

10 minutes ago, Dirty Butter said:

It may be that you have something maybe in the wordpress part that is redirecting in some odd way. Try seeing if you can see a test file at the store root level at this point from csrocketry.com. If it 404's then it's some kind of redirect issue.

That's all I can think of. If that's not the issue, it's time for you to get much more knowledgeable help than I can provide. @bsmitheris busy right now and not on very much, so maybe  @bsandall or @havenswift-hosting will be able to spot how to fix this. Of course you can always pay for a month's support from CC and let them fix it for you.

Well, I had support from a previous version purchase that disappeared, Hence my lack of desire to buy again.

Link to comment
Share on other sites

1 minute ago, Christopher Short said:

Just manually upgraded to 6.1.7, got another new admin so hopefully this will be fixed. Got the setup to work this time.

You've got to be doing something wrong or unusual. I've upgraded 12 stores so far today and all have been fine keeping existing paths. 

Do not upload the admin folder and admin.php file without first renaming them accordingly or after they have uploaded. 

 

Screen Shot 2017-04-20 at 14.36.40.png

Link to comment
Share on other sites

19 minutes ago, Al Brookbanks said:

You've got to be doing something wrong or unusual. I've upgraded 12 stores so far today and all have been fine keeping existing paths. 

Do not upload the admin folder and admin.php file without first renaming them accordingly or after they have uploaded. 

 

Screen Shot 2017-04-20 at 14.36.40.png

I followed this exact....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...