Jump to content

Upgrade 6.1.0 to 6.1.5


Recommended Posts

  1. I did the update by unzipping the file, copying the directories and files to internet.  I then did store.com/setup/index.php and it ran the update.  My problem when I went to check the database files there are a bunch of errors, mostly 2 types. 
    1.  CubeCart_admin_users.admin_id has a key type KEY but expecting PRIMARY.
    2.  CubeCart_category.cat_parent_id has no key set. Expecting KEY.
  2. How do I fix the above database errors?  There are 17 errors.
  3. CubeCart Version Date
    6.1.5 Monday, 27 March 2017
    6.1.4 Monday, 27 March 2017
    6.1.2 Monday, 27 March 2017
    6.1.0 Monday, 27 March 2017
    6.0.9 Thursday, 14 January 2016
Edited by Crysties
further comment
Link to comment
Share on other sites

  • 4 weeks later...

Were you trying to use Admin upgrade from 6.1.6 to 6.1.7? That was supposed to properly upgrade from admin, but 6.1.6 turned out not to be stable. That's why 6.1.7 followed soon after.

Assuming you had not previously upgraded to 6.1.6, follow the manual upgrade directions, rather than the upgrade from within CC Admin. See the CC announcement of 6.1.6 for directions on manual upgrade.

Link to comment
Share on other sites

  • 4 weeks later...

I must admit to being rather concerned about the number of problems that are reported.

I was looking at manually upgrading v6.1.1 to 6.1.7 but do not want to risk losing all.
I see that my admin folder has the new .xxxxxx suffix.
Is it possible to do a new 6.1.7 install and tie this in to my existing database without losing the data?

thanks

Dave
 

Edited by detectorman
Asked a silly question
Link to comment
Share on other sites

You wouldnt "lose all" by doing a manual upgrade and if you do a full file and database backup (as you should do before each and every upgrade !) then even if a catastrophe happens, it is easy to roll back.  I suppose it would be possible to do what you are asking but it is more work and doesnt achieve anything.  A manual upgrade to 6.1.7 is easy to do by following the instructions although there are several patches that are needed which will be included in 6.1.8 which is due out very shortly so I would suggest waiting a day or so until it is released.

Ian

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...