Jump to content

6.0.10 to 6.1.5


keat
 Share

Recommended Posts

I'm still seeing a number of orders where random content is missing, so before I raise this as a support ticket, I guess that i ought to update the site to the latest version.

Are there any differences in the database between 6.0.10 and 6.1.5, as I'll be performing an update on a mirror image, it would be easier if I could get away with just updating files.

 

Link to comment
Share on other sites

The issue of line items missing is complex and as far as we are aware it is fixed in 6.1.5. Alec was a massive help. 

The issue we think came around low stock items in the basket. Say you have 3 items in your basket. Two have plenty of stock and one is the last one. If the stock level is reduced to zero when the order is placed (transferred to payment). If the customer users the browser back button it could screw things up as technically the item is now out of stock. 

If the stock change time is "Processing" then this isn't going to happen as the stock changes after payment. Processing is the default setting. 

Link to comment
Share on other sites

OK that is what I thought but wanted to make sure.  This problem is massively affecting one of our clients but they arent on 6.1.5 yet so am encouraging them to upgrade so they can see if this fixes their issue.

They run it at Pending status (and cannot do it any other way for their business) but do have lots of items that are low in stock and also have lots of customers that create orders, come back to them in hours or days later to add / subtract items but also use the back button a lot as well.  This results in orders being the wrong amount and in many cases shipping and tax being wrong as well.

Link to comment
Share on other sites

Seeing how we are a little off topic, can I step in with addtional info regarding missing line items.

 

We do not use stock levels on the cart.

Every item is marked as stock level zero in the database, but 'use stock level' is unchecked.

If, and only if an item physically goes out of stock, is  'use stock level' checked.

Also, the store is configured to reduce stock when completed.

We had another one of these orders this week, with about 15 items missing from an oder of around 30.

I'm hoping 6.1.5 will fix this.

 

 

 

2 hours ago, havenswift-hosting said:

OK that is what I thought but wanted to make sure.  This problem is massively affecting one of our clients but they arent on 6.1.5 yet so am encouraging them to upgrade so they can see if this fixes their issue.

They run it at Pending status (and cannot do it any other way for their business) but do have lots of items that are low in stock and also have lots of customers that create orders, come back to them in hours or days later to add / subtract items but also use the back button a lot as well.  This results in orders being the wrong amount and in many cases shipping and tax being wrong as well.

Ian.

 

I have an idea that might over come this.

We have store email sent at the pending stage, and also suffer where customers will click the checkout button (email now sent to admin), then go back and change something. The store doesn't send a second email, which then causes all sorts of issues.

Admin confirmation email doesn't tally with payment, with sub totals incorrect.

I have another thread open for this.

Link to comment
Share on other sites

  • 1 month later...

I saw this issue today and I am running 6.1.7. The customer order 12 parts that brought the stock to zero as there were only 12 items. The email to the admin showed no items, see below.

However the order inventory had all the correct details. 

The email looked like this:

Item

Quantity

Cost

   

$0.00

 

Shipping: (Postage)

$0.00

 

Discount:

$27.00

 

Subtotal:

$180.00

 

Order Total:

$153.00

 

As Al said there is an issue with low stock, as in this case.

Is there any further data required to help with this issue?

Link to comment
Share on other sites

I hope we can find a fix, but like I've previously stated, whatever is causing the issue at my end is unlikely to be stock related.

I've had orders where as many as 10 different random items, will be missing, not only from the email, but also the cart and order_summary.

 

From what i've gathered from customers, it does appear to happen around the checkout stages, maybe somewhere between pending and processing, but being unable to reporoduce it, i couldn't be certain.

 

Link to comment
Share on other sites

Just now, keat said:

I hope we can find a fix, but like I've previously stated, whatever is causing the issue at my end is unlikely to be stock related.

I've had orders where as many as 10 different random items, will be missing, not only from the email, but also the cart and order_summary.

 

From what i've gathered from customers, it does appear to happen around the checkout stages, maybe somewhere between pending and processing, but being unable to reporoduce it, i couldn't be certain.

 

Maybe there are a few scenarios. Could a deleted product apply to your situation?

Link to comment
Share on other sites

I don't think so Al.

Some of these things have happened in the dead of night, plus we don't really delete a great deal, due to having a yearly catalogue.

The only items we delete would be stock clearance items, and maybe no more than 1 per week, during normal working hours.

Unless of course a customer added a stock clearance item to his cart, along with 20 other normal items, then at some point before he checked out, we deleted the stock clearance item.

But would this clear out a whole cart, or a number of random other items.

 

We've had at least two since updating to 6.1.7, however, both of these have happened around the same time where I've been making adjustments to core cart files and have had to perform cache clears, so I'm discounting those two for now.

Link to comment
Share on other sites

Not for me.

When this happens, the missing items are null everywhere, email, cart, order_summary.

 

Incidentally, I've just tried the missing item theory. I created atest item, added this to my cart with 10 other items, and then deleted the test item within admin.

Pressing the checkout button gives a message about the item being no longer available, nothing else was affected.

I then did the same, but deleted the part once I landed on the Paypal page.  I didn't make a payment, and returned back to the cart to be greeted with the same message about my test item being unavailable.

Link to comment
Share on other sites

The site is at 6.1.7.

However, like I say, I've had 2 occurances since i updated, but on both occasions, I was resolving a few mod issues which hadn't migrated, so at this stage, I'm putting them down to me swapping files over, and cache clears etc.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...