Jump to content
Paleo

Can't update to latest version

Recommended Posts

It's to be expected that it did the re-naming - 6.1.6 to 6.1.7 shouldn't have all these naming issues.

Just so everything matches with the active, new versions, and what's in global.inc.lphp and all other useless admin named stuff is deleted - you are fine.

Congratulations!!! That which does not kill us makes us stronger!

 

Share this post


Link to post
Share on other sites

Well, yes and no. Haha

Because I just hit a snag.

When I try to edit something, I get this message:

Forbidden

You don't have permission to access /admin_xxxx.php on this server.

Share this post


Link to post
Share on other sites

Oh My!!! And you've checked that global.inc.php entries match the naming for your admin_XXX folder and admin_XXX.php file?

What is the permission for global.inc.php in the properties of that file?

Share this post


Link to post
Share on other sites
50 minutes ago, Dirty Butter said:

Oh My!!! And you've checked that global.inc.php entries match the naming for your admin_XXX folder and admin_XXX.php file?

What is the permission for global.inc.php in the properties of that file?

File and folder names are correct.

Permissions for global.inc.php are set at read on all 3 options.

So far, it has only happened when I try to edit my keywords in the search engine tab of store settings.

Now also the copyright tab.

Something about editing the store settings?

Share this post


Link to post
Share on other sites

Have you created the error log?

What messages do you get when you try to make a Store Setting change?

Are you logging into Admin with the correct admin_xxx.php link or still using your old bookmarked login screen?

Share this post


Link to post
Share on other sites

When I edit a store settings, it send me to a blank page with nothing on it but:

Forbidden

You don't have permission to access /admin_xxxx.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

 

I'm using the correct link and all that.

Made the error log .php file and stuck it in the main folder. Didn't seem to do anything, unless I don't have it in the right folder. It's in the absolute main folder. Does it need to be in a specific CC folder?

Wait. I found error_log in the public_html folder.

I can't get it to open, though.

Edited by Paleo
Typo

Share this post


Link to post
Share on other sites

Okay, got the error log to load. It kept crashing my browser for some reason.

Here is the error log:

[06-Apr-2017 13:07:36 America/Chicago] PHP Warning:  unlink(/home/XXXX/public_html/setup) [<a href='http://docs.php.net/manual/en/function.unlink.php'>function.unlink.php</a>]: No such file or directory in /home/YYYY/public_html/admin_xxxx/sources/dashboard.index.inc.php on line 45
[06-Apr-2017 15:42:58 America/Chicago] PHP Warning:  array_keys() expects parameter 1 to be array, boolean given in /home/YYYY/public_html/admin_xxxx/sources/dashboard.index.inc.php on line 311

Share this post


Link to post
Share on other sites

Have you deleted the setup folder from the store root? Have you cleared all cache except images within CC and in your browser?

The error message about "expects parameter 1 to be array, boolean" is a known notice that doesn't cause problems and I think will be fixed in a future version of CC.

Delete the contents of the error log, too. It must be huge if it crashed.

 

Share this post


Link to post
Share on other sites
1 hour ago, Dirty Butter said:

Have you deleted the setup folder from the store root? Have you cleared all cache except images within CC and in your browser?

The error message about "expects parameter 1 to be array, boolean" is a known notice that doesn't cause problems and I think will be fixed in a future version of CC.

Delete the contents of the error log, too. It must be huge if it crashed.

 

Ha! That did it.

I cleared the cache and sql cache, then cleared all browser history.

Logged back in, and store settings are working again.

As odd as it sounds, "Dirty Butter is my hero." Haha

Share this post


Link to post
Share on other sites

PHEW!!! Just call me DB :)

There were a LOT of database table changes in 6.1.5 upgrade. So there were calls to the database tables that couldn't find the right fields when you were still working from the old cached files.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...