Jump to content

[Resolved] Google Microdata


niallB
 Share

Recommended Posts

I wonder if someone can help or advise. I tried messaging Havenswift a couple days ago but no answer.  I installed the Google schema.org Microdata  plugin on my site but when i click on it it gives the message in the image. I can't access it to get it working. Any ideas or is there a plugin for this that someone can recommend?

I checked with the hosting and ioncube is installed. I installed it with the token option. Is there something I may be missing or need to do. Or is there documentation. I also logged out and logged back in.

Kind regards

Niall

google microdata.JPG

Link to comment
Share on other sites

I assume you don't have IonCube installed which might be why you see the issue. rename or delete the module using FTP, it's found in /modules/plugins/ directory. once removed your store is back to being available and the root cause can be identified and fixed.

 

Link to comment
Share on other sites

Hi Niall

As others have said (and it says in my signature), please use our ticket system for support issues as while I am on here most days, there is no guarantee and didnt see your message until just now.

I have just seen that we only have a single version available via on the marketplace, so it could be that your ionCube version isnt compatible (or maybe you dont have it installed correctly).  Please check PHP Info in your store and let me know - in the meantime, I will get both encoded versions added to the marketplace

Ian

 

Link to comment
Share on other sites

Hiya Ian,

Sorry I didn't realise about the ticket system. I'll know for the next time. Apologises.

The ioncube was running but I reinstalled the newer version of ioncube 6.9 again but still no joy. I'll try reinstalling plugin. The marketplace seems to be down at moment so 'll try again in morning. 

Cheers

Niall

Link to comment
Share on other sites

i had an issue but i can't remember what problem it caused, but i had to downgrade php version from 7 down to 5.6.30 for this plugin to work correctly, may or may not be related to your issue.

Did you ever update this Ian to run on php 7?

 

 

Link to comment
Share on other sites

This can be caused by the IonCube encoded version, php 7 requires the newest ioncube loaders and the module to be encoded using IonCube for PHP 5.6 with the latest encoders.

It's for this reason I offer two downloads for all my modules, those for PHP 5.6 and above, and 5.5 and below.

  • Like 1
Link to comment
Share on other sites

Hi Niall

I have updated the Microdata plugin so two versions are available (for PHP 5.6 and above and another for PHP 5.5 and below) but unfortunately due to some caching issues with the Marketplace (which I have reported to Al), these are not showing.

If you would like to register as a client at our site and open a ticket, I can let you have the correct version that way

Ian

  • Like 1
Link to comment
Share on other sites

i have a paid licence code now ian, but we had to downgrade the php or the ioncube version back in November to run it, so now going back to php7 (because its noticeable faster) but wasn't sure if to delete the other version first or just run the new version with token

 

Link to comment
Share on other sites

Well that will depend on what version of php / ionCube encoder you are currently running. If going to php 7 (good choice btw as it is much quicker !) then best to download the 5.6_and_above version from the marketplace and simply upload over the top of what you have now, once you have switched to php 7.  

Link to comment
Share on other sites

2 minutes ago, foz1234 said:

All sorted Ian thank you, i had updated to php 7.1 but seems as yet ioncube is not supported, so i ended up on php 7.0

OK great - 7.0 is supported by ionCube encoder V9 and you are correct that php 7.1 isnt yet supported but is supposed to be when V10 comes out but no timescale from ionCube yet

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...