Jump to content

Add e-mail to Mailing list doesn't work (6.1.7)


SergeiG
 Share

Recommended Posts

I have a clean copy of CubeCart on my local computer. I registered as a new customer and clicked the 'Subscribe to newsletter' box - my account info shows me as subscribed. I can unsubscribe and re-subscribe with no issues.

Could you perhaps outline the steps you are taking on your end to receive the errors you have mentioned? If we can reproduce it, we can fix it.

Edited by bsandall
Link to comment
Share on other sites

22 minutes ago, bsandall said:

I have a clean copy of CubeCart on my local computer. I registered as a new customer and clicked the 'Subscribe to newsletter' box - my account info shows me as subscribed. I can unsubscribe and re-subscribe with no issues.

Could you perhaps outline the steps you are taking on your end to receive the errors you have mentioned? If we can reproduce it, we can fix it.

Right now I repeat next steps:

Download CubeCart 6.1.7, install it (without mistakes) on clean environment, open home page, input e-mail into "Mailing List", press Subscribe.

The result - a screen scroll up, no information/error messages, no e-mail in the mailing list on admin side.

 

mailing_list_test.mp4

Link to comment
Share on other sites

14 minutes ago, Dirty Butter said:

Strange!!! I just tested on a stock test store with yesterday's commit. The subscribe/unsubscribe works from all locations, including the footer.

Curious indeed. I'm using the latest code from GitHub on a local WAMP server. Very interesting.

EDIT: I've narrowed it down to the validation JavaScript. Removing the function starting on line 106 of 3.cubecart.validate.js allowed me to successfully subscribe from the form in the footer.

With that function there, the page appears to load after submitting, but if I refresh it asks if I want to resend the POST request, indicating that it did not redirect.

Furthermore, dumping the POST data shows only the CSRF token - no email or other data that should have been there.

@Dirty Butter Is your newsletter form in the footer edited at all, or are you using a clean Foundation skin?

Edited by bsandall
Link to comment
Share on other sites

  • 3 weeks later...

Did anyone ever find a fix for this? I am having exactly the same issue (on CC6.1.8) when entering an email address mailing list subscription box in the footer - after clicking the "Subscribe" button, I get a screen scroll up, no information/error messages, and no e-mail added in the mailing list on admin side.

Link to comment
Share on other sites

On 5/28/2017 at 2:07 AM, Gigi71 said:

Did anyone ever find a fix for this? I am having exactly the same issue (on CC6.1.8) when entering an email address mailing list subscription box in the footer - after clicking the "Subscribe" button, I get a screen scroll up, no information/error messages, and no e-mail added in the mailing list on admin side.

Hello! As I know, this issue haven't been solved yet. From my perspective, it takes time because only small number of users meet this issue and it difficult to developers reproduce in their environments.

Link to comment
Share on other sites

  • 4 months later...

I have a new installation of 6.1.10, same issue as above :(

" when entering an email address mailing list subscription box in the footer - after clicking the "Subscribe" button, I get a screen scroll up, no information/error messages, and no e-mail added in the mailing list on admin side. "

Link to comment
Share on other sites

On 5/9/2017 at 1:42 PM, bsandall said:

@Dirty Butter Is your newsletter form in the footer edited at all, or are you using a clean Foundation skin?

My newsletter footer link is based on SFWS's Mailchimp plugin on plushcatalog. I tried to create something similar on dirtybutterestates in the footer using the embeded code straight from MC, but it did not work properly.

Link to comment
Share on other sites

  • 3 weeks later...
On 10/3/2017 at 6:51 AM, Dirty Butter said:

My newsletter footer link is based on SFWS's Mailchimp plugin on plushcatalog. I tried to create something similar on dirtybutterestates in the footer using the embeded code straight from MC, but it did not work properly.

Did you ever open an issue on GitHub for this?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...