Jump to content

[Solved] Urgent! Order emails stop to send


SergeiG
 Share

Recommended Posts

Hello!

Today I found that customers don't receive any emails about their orders, I also don't receive any confirmations about new orders. 

I don't have any clue where this issue can be.

1) During making a test order I didn't receive any errors on a front-end side. 

2) 'E-mail' log doesn't show that any e-mails were send. (!!!)

3) 'Error log' is clear for ''admin" and "system" tabs

4) Test e-mail from "Store settings/Advanced" are sent and came to me without any issues.

 

Last changes which I made before this issue happen:

- #1630 was deployed

- 'Sender's Email Address' was changed in "Store settings/Advanced".

 

I replace modified order.class.php by original version from 6.1.5 pack, clear cache at the back-end. It doesn't help.

Additons:

When I change status to "Processing" - nothing happen. If after that I change a status back to "Pending" then "New order" e-mail goes to an admin, but "Order confirmation" e-mail isn't send to a customer.

Edited by SergeiG
Additional info added
Link to comment
Share on other sites

In store settings/advanced, enable debugging.

Place a dummy order and check the debug log in the bottom of your browser to see if there are any errors being displayed.

In the file root of your store create a file named   ini-custom.inc.php    and paste the following code inside.

<?php
# Custom initialization commands
# Filename: ini-custom.inc.php
# File location: main CubeCart folder

ini_set('memory_limit', '256M');
ini_set('max_execution_time', '60');
ini_set('error_log', 'error_log');
ini_set('log_errors', 'on');

?>

 

try to place another dummy order, and then check error.log in the file root of your store.

  • Like 1
Link to comment
Share on other sites

  • SergeiG changed the title to [Solved] Urgent! Order emails stop to send
1 hour ago, keat said:

In store settings/advanced, enable debugging.

Place a dummy order and check the debug log in the bottom of your browser to see if there are any errors being displayed.

In the file root of your store create a file named   ini-custom.inc.php    and paste the following code inside.

<?php
# Custom initialization commands
# Filename: ini-custom.inc.php
# File location: main CubeCart folder

ini_set('memory_limit', '256M');
ini_set('max_execution_time', '60');
ini_set('error_log', 'error_log');
ini_set('log_errors', 'on');

?>

 

try to place another dummy order, and then check error.log in the file root of your store.

Hello!

Big thank you for the advice about debugging mode. It didn't help, but will be useful in future.

I found the reason of this issue - during changes in additional language file I loose 'email_ru_RU.xml' file, as the result, when a customer (who uses this language) made an order, the engine couldn't create an email.

It's absolutely my fault, however a situation, when one or several language files aren't exist, requires two solutions:

1) Error message in log-file

2) An attempt to send an e-mail by usage a default (english) language.

Link to comment
Share on other sites

1 hour ago, SergeiG said:

It's absolutely my fault, however a situation, when one or several language files aren't exist, requires two solutions:

1) Error message in log-file

2) An attempt to send an e-mail by usage a default (english) language.

Sounds like a good Feature suggestion. See my signature for the link to it, so you can add your suggestion (with a link to this discussion). Also, please link back to it here, so others will see it and vote.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...