Jump to content

Emails not working after upgrade to 6.1.12


RichardW3
 Share

Recommended Posts

Since the upgrade the system seems to be working normally except that when an order is received, the system no longer sends automatic emails: to Sales to notify them of the incoming order, and to the Customer acknowledging the order. I suspect that a procedure (or two) has got 'lost' during the upgrade, but as I know nothing of the internal structure of the Cubecart system, I don't know where to start looking. I'm hoping I can just copy the missing procedure(s) in from a backup to minimise disruption (ie I'd rather not have to revert to the previous version and try again).

Something similar happened when we attempted to upgrade to 6.1.5 earlier in the year, but on that occasion we merely restored the previous version and stuck with it until now.

I've noticed another recent post about a different problem with the 6.1.12 upgrade, and note that apparently we have both attempted to run the upgrade via the link on the Admin dashboard - apparently this has not been working for all recent 6.1.xx upgrades, and if this is so, I suggest it should be fixed or removed altogether. I note the link to the more complicated upgrade procedure given in the reply to that post.

Link to comment
Share on other sites

  • 2 weeks later...

  • 2 weeks later...
18 minutes ago, bsmither said:

Please know that the customer does not get an mail when the order goes to Pending. The only exception is when your store is using the Printed Order Form (POF) and that the POF is set to send a courtesy reminder email.

 

i as admin get an email that there is pending order set in "CC settings", also paymet confirmation, as customer I didn't get email your order is processing + when changed status in admin site as "complete" no email sent as confirmation.

Link to comment
Share on other sites

18 minutes ago, bsmither said:

In admin, Email Log, please determine if there are log entries for any email sent to the customer's email address.

yes, all in email log are ticked and tried resend no email getting through

Edited by eduardj
Link to comment
Share on other sites

You say there is a log entry for Order Confirmation #2017-(whatever) sent to the customer's email address.

But the customer has not received it.

Any chance this email is in the customer's spam folder?

In your hosting account's control panel (Cpanel?), do you have the tool (Track Delivery) that will allow you to test sending an email to the customer's address?

Link to comment
Share on other sites

On 17/11/2017 at 11:02 PM, bsmither said:

You say there is a log entry for Order Confirmation #2017-(whatever) sent to the customer's email address.

But the customer has not received it.

Any chance this email is in the customer's spam folder?

In your hosting account's control panel (Cpanel?), do you have the tool (Track Delivery) that will allow you to test sending an email to the customer's address?

Yes, in log entry for emails sent I have that confirmed, I have cleared cashe and made some changes now I need to wait if I get any more complains from customers not receiving email confirmations.

Thanks for trying to help out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...