Jump to content

Newbie - Neither Admin nor Customer receives email


stevebo
 Share

Recommended Posts

Note:  I have installed Cubecart on a Windows Hosting Server, so that might be the problem, even though everything else about Cubecart seems to work.

Anyway, I cannot for the life of me figure out how to get email confirmation of an order / purchase.  I can successfully receive email using "Test (After Save)" from Dashboard > Settings > Advanced Settings

When I complete my purchase (and pay via the Braintree / PayPal extension) I receive no email confirmation.  However, my credit card is indeed getting charged through the Gateway each time I run a test.

In Settings > Features > Misc > Order status for admin email notifications  I have tried both Processing and Order Complete to no avail. I also check Force Order Completed Emails but nothing works.

What am I missing?  What event triggers sending an email?   If it makes any difference, I do not sell anything that requires shipping, but I still want to receive notifications.  Any help appreciated.

Thanks,

Steve

Link to comment
Share on other sites

Welcome stevebo! Glad to see you made it to the forums.

Unfortunately, the drop-down selector when an admin receives an email for a new order includes all possible order statuses, but only the Pending and Processing choices are valid.

The Test button should throw up a window showing the entire conversation between CubeCart and the SMTP server specified. Hopefully you see that -- in addition to the test email being received.

Customers will receive emails once the order goes to Processing, and more when it goes to Completed.

Please make sure there is a language enabled in admin, Languages. Then, in admin, Email Templates, make sure there are at least one flag showing in the Translations column.

You may also want to view Admin, Email Log.

Link to comment
Share on other sites

2 hours ago, bsmither said:

Customers will receive emails once the order goes to Processing, and more when it goes to Completed.

Hi Bsmither, thank you for taking the time to respond.  I was finally able to get the system to generate an email by -- as you said -- changing the status on an order in the Admin > Orders page to Completed.  However the only message generated went to the customer (me).  The admin (also me with a different email address) receives nothing.  Not when the order was placed, not when I change the status and not when the Gateway approves the transaction.

I wonder if I just don't understand how the system is supposed to work. I just assume that once a cart is paid for that everyone (admin and customer) receives an email message.  Is this assumption correct?

Thanks,

Steve

Link to comment
Share on other sites

Unfortunately, the drop-down selector that chooses when an admin receives an email for a new order does include all possible order statuses, but only the Pending and Processing choices are valid.

So, in admin, Store Settings, Features tab, Misc section, "Order status for admin email notifications", set this to "Pending" for further experiments.

Link to comment
Share on other sites

OK that's good info.  I did the things you suggested.  I've attached a screenshot of the setup.

Once I make the purchase (but just before I go to the Gateway) I see the purchase in Customers > Orders > Orders Overview.  I've attached both the order screen and the order screen.

But still no email verification.  

However, once I go to the order itself and mark it as Complete, then the email is sent.  And even then, it only gets sent to the customer.

Am I missing something basic here?

Many thanks,

Steve

 

Cubecart Setup.PNG

Cubecart.PNG

Cubecart2.PNG

Cubecart Complete.PNG

Link to comment
Share on other sites

Good idea! I just checked and no other emails were generated according to the log.  Maybe I've got some setting selected that prevents confirmation messages?

It's just strange.  I could understand if it never sent a message, but only when I mark a transaction completed is odd.

Link to comment
Share on other sites

The admin does not get an email when an order goes to Complete. The customer does.

In admin, Store Settings, Advanced tab, be sure there is a valid email for "Sender's Email Address". (Also, you should know there are some hosting providers whose server environments have extreme difficulty emailing to the same domain as that of the store. That is, if the email '[email protected]' is handled on the same server as 'www.bo.com', it may be impossible to receive that email.)

Next, in admin, Administrators, edit your admin profile. Make sure you have "Receive order notifications?" enabled. If this email is different than the store's general "Sender's Email Address", then CubeCart should send an email to both addresses. As an experiment, make your admin profile email address to something not the store's email address domain.

 

Link to comment
Share on other sites

OMG it works!  But now I can't get it to fail the way it has been failing.

I blame my browser cache.  I discovered this when I noticed that when checking out, Cubecart stopped prompting me for customer info and populated the screen with my previous order's information.

So now every time I make a change to the admin panel, I make sure to refresh the browser for each page of the Cubecart system.  This seems to work and as I mentioned, I now cannot get it to fail.

I really appreciate all your help.  Can I send you some kind of gift card?

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...