Jump to content

SSL & Cubecart


stevebo
 Share

Recommended Posts

Hi Cubecart community!

I just upgraded my website to have an SSL secure certificate.  However, this seems to break Cubecart.  Well maybe not exactly break it, but it isn't secure.

The shopping cart still works fine in an un-secure mode: http://fitpacking.com/cubecart/index.php, as it bypasses SSL.  But when I get to the checkout screen, I see this "not secure" browser window:

image.png.60511b1f4d324d76036035892de717ef.png

 

I have tried to force the issue using https://fitpacking.com/cubecart/index.php but this somehow ruins the markup or breaks the Javascript or something.

Do you have any suggestions on how to get the SSL certificate working with Cubecart?

Thanks,

Steve

 

Edited by stevebo
Link to comment
Share on other sites

Wow, I hadn't seen that.

I go into the Admin page, check Enable SSL and set Store URL to https://fitpacking.com/cubecart.  When I hit save, it changes the URL to http://fitpacking.com/cubecart.  Then when I go to the site I receive the following error (even after clearing cookies): 

This page isn’t working

fitpacking.com redirected you too many times.

ERR_TOO_MANY_REDIRECTS\
 
 
 
 
Link to comment
Share on other sites

Also check to see if someone at sometime made an edit to the .htaccess file in either or both the fitpacking main folder and CubeCart's main folder.

If there is a directive in either that does the same thing that CubeCart is trying to do, then mayhaps this is the cause of the "too many redirects" issue.

Yes, CubeCart actually does want the "non-ssl" variant of your store's URL in Store Settings, SSL tab.

Link to comment
Share on other sites

I checked .htaccess and no changes in either folder.

One possibility is that because this runs on a windows server, https://www.fitpacking.com/cubecart won't see index.php, so I wrote up a re-direct page index.html that uses this:

<meta http-equiv="refresh" content="0; URL=https://www.fitpacking.com/cubecart/index.php">

This re-directs to https://fitpacking.com/cubecart/index.php where I receive the Too Many Redirects error.  Maybe it's a Windows thing?

But even when I directly type in the URL https://fitpacking.com/cubecart/index.php, I still get the error although sometimes the error is: 503 Service Temporarily Unavailable

I feel like I'm missing something really obvious.

Link to comment
Share on other sites

Mayhaps it isn't because you have a Windows server (I have two), it is because the web server is IIS (which I do not use). As such, there is a way (I forget how now) to order the default document preferences so that index.php is higher on the list when no document is specified.

Be aware that there exists at some places in CubeCart's web pages a URL that is simply www.mysite.com/cubecart/ with no actual document mentioned. As such, this may cause a round-robin with index.html (if it has a higher position in the default document list) and index.php.

I occasionally get a 503 with one of my dev boxes -- this particular dev box does not have PHP-FPM capability. So, after x-number of page requests, something gets exhausted and PHP just quits. (On one of the server boxes, I have a service wrapper on the PHP process that, when PHP quits, the wrapper restarts it. Usually in a fraction of a second.)

Link to comment
Share on other sites

From the exact URL you gave us (/cubecart without a trailing slash), I get a 301 to /cubecart/ (with a trailing slash). That tells me there is something watching for URLs that do not conform to a specific syntax of your installation of CubeCart. And it isn't CubeCart.

After I ask for the URL the 301 told me to use (/cubecart/ with a trailing slash), I get a 301 to /cubecart/Index.php (with an uppercase I). That tells me there is something watching for URLs that do not conform to a specific syntax of your installation of CubeCart. This could be CubeCart as I see there is a header that wants to set a CubeCart cookie.

Thereafter, when asking for the URL the 301 told me to use (/cubecart/Index.php with an uppercase I), I get a 301 to /cubecart/Index.php (with an uppercase I).

I also see that you are running PleskWin for which there may be a server directive, or perhaps there is a directive in IIS, or both, that is issuing the 301 specifying the Index.php (with an uppercase I) where the other specifically is looking for index.php (with a lowercase i).

Look in /includes/global.inc.php for any value that includes Index.php (with an uppercase I). If there are any values that mention the URL or path to CubeCart, know that none of these values should actually have index.php as part of it.

Link to comment
Share on other sites

Well what do you know?  It was an issue with the hosting company, maybe the IIS server as you indicated (they didn't tell me) but they fixed it.  So all of your settings worked, it was an issue on their end.  I very much appreciate your sage advice.  Thank you!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...