Jump to content

Installing / Setup Cubecart 6.1.13 in Godaddy Cpanel


Recommended Posts

Hi all.

I am pretty new to the whole selling online through a website scene and I would really like some help.

I watched the video of how to install Cubecart on Vimeo ( https://vimeo.co*m/118587171 ) and it looks really easy!, So i thought I'd give it a shot.

My website is hosted on Godaddy and always has been. I know the very basics of using Godaddy and the file manager so I followed the steps the video gives.

I uploaded the ext file to my domain.com/shop and extracted it, created a database (although the database system is slightly different through Godaddy I managed to create it). I then continued to the www.domain.com/shop/setup and was given a line of text that says (and as the video suggests, A file may need to be changed to 'writable') the Cache file was required to be changed to writable.

I refreshed by /shop/setup page and now there is a landing page which reads:

 

500 (Internal Server) Error

...that we're working furiously to correct. Things will be up and running again soon. Thanks for your patience.

 

The setup page does not load and there seems to be an 'internal server error' so I cannot continue the setup.

Has this happened to anyone else?, Can anyone suggest anything?. I have tried deleting the database I created and all the files and starting fresh but still the same problem appears. I have also tried picking an older version of Cubecart but still the same error happens.

Also to mention, I did have to upgrade my php option to 5.4 (should I also upgrade it to 5.6 or is this not needed?).
Picture attached of the error message.

Thanks for reading and I hope someone has a solution for me :)

a0b7571d35b771a1b3a5bfc06eac6db8.png

Link to comment
Share on other sites

You should probably upgrade php again - 5.6 is the very minimum you should be running and there is no reason not to run 7.0 or even 7.1

The error is probably being caused by an invalid directive within an .htaccess file - you might still have directives that are envoking an earlier php version.  This is a Hosting issue though and nothing to do with CubeCart so you should contact their support

Ian

Link to comment
Share on other sites

A 500ISE is sent when the web server has determined there is something it is being told to do is wrong (generally in the .htaccess file*), or PHP has crashed.

If there is a problem that involves CubeCart, we ask that you create the error_log.

* There may be a directive in the .htaccess file in the main domain.com folder. CubeCart's setup probably hasn't had a chance to write it's own file to /shop/ at this point.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...