Jump to content

Enhanced Manufacturers


CubeCart Bot
 Share

Recommended Posts

  • 4 years later...

Hi All,

I have just installed this plugin into a localhosted cubecart site but unfortunately I must have missed a setup step somewhere because it does seem to firstly list all of the manufacturers and also if you select a manufacturer it displays the logo ok but displays that there are no products found, which is not right as there are products for this and other manufacturers. Also in the right hand column where there is a box called "Manufacturers" there is a please select when you try this you get just the first manufacturer and nothing else, if you select this manufacturer you get the same result of no products. So is there a setup step that I have forgotten or missed that will solve my issue.

Hope somebody can help as this could solve the clients issues

Best Regards,

Peterp

 

Link to comment
Share on other sites

I cannot help troubleshoot the code -- it is likely ioncube encoded (as is essentially all of Haveswift's products).

If you enable CubeCart's debug mode, then call up a page of a manufacturer's assigned products, we should be able to see the database query the module makes when fetching the products of that manufacturer (assuming the module uses CubeCart's database code).

Link to comment
Share on other sites

Hi Brian,

Thanks for responding, I have switched on the debugging and tried running it all again. On examination of the log there seems to be some errors with reference to the Enhanced manufacturing. I have attached a screen shot what do you think.

when I was installing ioncube I had some issues as well but I thought they had been corrected by the ioncube support but maybe they haven't.

Would it be worthwhile re installing the ioncube application

best regards,

peterp

Admin Control Panel - localhost.pdf

Link to comment
Share on other sites

Posted (edited)

I don't see this as an issue with ionCube.

The 'Undefined index' messages can be ignored. As can the 'Unknown or incorrect time zone' messages.

The errors with 'unserialize()' and the following 'access array offset' are concerning, and may be because of...

Do the instructions that came with Havenswift's module indicate that the module is locked to a given domain name? Any mention that the module will also work in 'localhost' - regardless of being locked to a domain name? When you purchased the module, did you have to indicate exactly where you would be using it? Is the module still in it's FREE seven-day trial period?

 

Edited by bsmither
Link to comment
Share on other sites

Hi Brian,

         There's no mention of it being locked to a particular domain name or that cannot work with a localhost The module is still in its free 7 day trial but it will end in about another 48hrs that why I'm a little concerned obviously I don't want waste my money unless I can see that is going to do first what is suppose to do and also whether that suit my clients need.

Thanks so much for your help it is always appreciated.

Best Regards,

Peterp

Link to comment
Share on other sites

The thought came to me that the module's admin screen must have some sort of advisory phrasings that would warn if the module is being used outside its licensed environment.

Ok, so it is in its trial period.

Getting back to CubeCart's debug mode... In that mode, at the bottom of the web page shown, there is a grey diagnostics section. We are interested in the query that looks like it is selecting products against a specific manufacturer id.

Once that query is found, it can be used in your database management utility to see if anything is actually being returned from the database.

 

Link to comment
Share on other sites

Hi Brian,

Sorry about the delayed response, I have been doing a little of investigation of my own and have come up with some issues which I think are causing the problem of no products being displayed when a manufacturer is selected from the drop down list.

So What I did was completely reinstall the extension and configured it on a totally different PC and surprises surprise it worked as it should so I then compared the settings from this PC to the other PC and found there was no difference. As you can imagine this has become quite frustrating and time consuming, I then by chance decided to search the products in admin using a filter and when the drop down filter was displayed I noticed that there are multiple Manufacturer entries, so I selected the first one and found it displayed no products so I then selected the next entry for the same manufacturer and found no products I then selected the last entry for the same manufacturer a guess what I got all of the products. So my next action was to delete the manufacturer and then I went back into the products selection in the admin and did the same filter and the top manufacturer was deleted but the other duplicates were still there and they don't show up in the manufactures selection in admin. Is they a way of getting rid of these duplicates so that I can start from the beginning. It seems that all of the testing I have been doing hasn't deleted the Manufacturers when I was testing the application.

Hope you can help

Best Regards,

Peterp

Link to comment
Share on other sites

Getting back to CubeCart's debug mode... In that mode, at the bottom of the web page shown, there is a grey diagnostics section. We are interested in the query that looks like it is selecting products against a specific manufacturer id. And any query that gets data from the CubeCart_manufacturers database table.

Once those queries are found, they can be used in your database management utility to see what, if anything, is actually being returned from the database.

 

Link to comment
Share on other sites

HI Brian

I have attached a screen shot copied the grey area of the storefront that we are using where we are trying to select a manufacturer  and see the products that are in the inventory for that manufacturer There is information below this but it not in the grey area do you need this as well

Best Regards,

Peterp

crius technologies grey area- localhost.pdf

Link to comment
Share on other sites

Use the mouse to swipe across all that diagnostic stuff - all the way to the bottom.

Copy it to the OS clipboard, paste it in a text editor (Notepad is fine). Save the text file. Attach that to a reply (or email it to me).

But looking at the error messages, those unserialize() errors really needs to have the publisher look at their code. I'm guessing that the serialized array (17 bytes is way too little to be correct) does not contain the data it is supposed to have.

 

Link to comment
Share on other sites

Hi Brian,

I have attached the whole error debug from the latest test. I have noticed another thing which may or may not mean anything the message I'm getting is that there is "another SEO for the same Item and the system has created one for me"  or words to that effect, it might mean nothing

Best Regards,

Peterp

enhance manufacturers debug.txt

Link to comment
Share on other sites

The SEO message is something you should look into later.

Using your local database app to examine the database, look in the table 'CubeCart_modules'. Find the row where the 'folders' column has the value "enhanced_manufacturers". The errors are generated immediately after this query (#11 in the list):

SELECT SQL_CALC_FOUND_ROWS `status`, `countries`
FROM `CubeCart_modules`
WHERE CubeCart_modules.folder = 'enhanced_manufacturers'
LIMIT 1;

Take note of the value in the 'countries' column of that row.

The amount of data that this column can hold is 255 bytes. Are there a lot of characters here, or are there about 22 or 23 characters?

Edited by bsmither
Link to comment
Share on other sites

Using your local database app to examine the database, look in the table 'CubeCart_config'. Find the row where the 'name' column has the value "enhanced_manufacturers".

Please let us know the value in the 'array' column of that row.

Link to comment
Share on other sites

I do not find anything wrong with unserializing that string (after base64 decoding it). So, I have no idea what the 17 byte string would be that PHP cannot unserialize.

But I do notice that one of the error messages:

Undefined index: localkey

may be an indicator of bad coding - the config array is using local_key.

I assume you are using the latest version of this plugin (v1.5).

Time to contact the publisher, @havenswift-hosting.

Link to comment
Share on other sites

Hi Brian,

       Thankyou so much for your patience and help unfortunately I have run out of testing time using the trial version and also this plugin seems to be too unstable for me to recommend it to my clients. Unfortunately this is going to be a complete deal breaker for  3 to 4 of my potential cubecart clients. One thing I did think of was is there a way that we can make an extra advance search selection in the foundation skin that possibly displays under the advanced search selection that will only select a manufacturer for an entered key phase just a thought.

Thanks again and your support is greatly appreciated,

Best Regards,

Peterp

Link to comment
Share on other sites

This is CubeCart Corp's demo site, the Advanced Search page (Foundation skin):

https://demo.cubecart.com/cc6/search.html

You said: "that will only select a manufacturer for an entered key phase". I am not sure what you mean by that.

On the demo search, select "Sony" as the manufacturer, and just use an asterisk for the search term. You will get all Sony products.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...