Jump to content

Bulk Update Sale Prices by Category


CubeCart Bot
 Share

Recommended Posts

  • 3 years later...

Upon installing this, l get the following error right away, from within control panel:

"Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance."

At some point, this error prevents me from even managing my extensions, so l have to manually delete by navigating my "modules" folder on the server.

I haven't purchased the extension, l was just trying to demo it. Maybe l need to purchase it? But l thought it was okay to demo it first.

 

I get the same error with the other discount plugins by Noodleman too.

I'm on the latest version of CubeCart - ignore my sig, l updated it, but the update won't update - you know how it is with this pandemic ...

Edited by cubicsquare
Link to comment
Share on other sites

  • 3 months later...
On 7/27/2021 at 8:39 AM, cubicsquare said:

I haven't purchased the extension, l was just trying to demo it. Maybe l need to purchase it? But l thought it was okay to demo it first.

I get the same error with the other discount plugins by Noodleman too.

You will get this for all Noodleman plugins and also all plugins developed by us.  You may be able to enable ionCube yourself in your hosting control panel but if not then you will need to move to a decent hosting company that installs this as part of their standard setup (like us !)

Link to comment
Share on other sites

  • 3 months later...

It should, however it hasen't been updated since 2017.

Which only means that, since it is encoded with ionCube, the encoded files must have been built with a matching version of the encoder for the version of PHP it is running under.

Even though the current encoded files are built for "PHP 5.6 and above", this does not mean they will work on any version of PHP7 - which your hosting provider has likely configured your hosted account to use.

The publisher, @Noodleman, will need to build encoded files for PHP 7.

 

  • Like 1
Link to comment
Share on other sites

15 hours ago, lyndsiesal said:

Thank you @bsmitherI do have php 7.2.34.  

PHP 7.2 stopped even receiving critical security updates over 1 1/2 years ago so running any site on this version is 100% not advised.  You would be much better contacting @Noodleman directly via his website and simply asking for a 7.4 encoded version of them and ensuring you stay on the latest supported version of PHP

Ian

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...