Jump to content
Sign in to follow this  
huggettm

Cant Promotional Codes

Recommended Posts

Posted (edited)

Hello forum,

I have an issue with my database with promotional coupons.

I can make a coupon in CC admin, however the code comes up blank. 

image.png.726132125f14bbd30f56e52985235acc.png 


If I type the code name in the database I can see it in cubecart admin.

However, In my database

image.png.c36c6ac83d2efa68ee56e2bc5473fe0b.png

 

On line 3 for the code; is the Default of "None" correct?

   

 

 

 

 

 

 

 

               

 

image.png

Edited by harrisorganic

Share this post


Link to post
Share on other sites

I believe what the database utility is simply saying is that for this column, a default value has not been declared. This is not the same as a 'zero-length-string'. Nor is it the same as NULL.

There was an issue posted in the Github about how certain sequences of letters/numbers/punctuation for coupon codes not getting into the database.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...