Jump to content
Martin Verkerk

Update problem 6.14 to 6.2.0

Recommended Posts

Hi,

I have make an upgrade from version 6.1.4 to version 6.2.0

The update is make with the default Foundation skin.

After the update is the new functions not active. 

With a new installation with version 6.2.0 works it correct.

With kind regards,

Martin Verkerk

Share this post


Link to post
Share on other sites

Did you rename the admin folder and file before uploading as per the instructions? If you just uploaded the files as they are from the extracted zip file then the active files won't have been overwritten. 

Share this post


Link to post
Share on other sites
30 minutes ago, Al Brookbanks said:

Did you rename the admin folder and file before uploading as per the instructions? If you just uploaded the files as they are from the extracted zip file then the active files won't have been overwritten. 

Where are these Instructions at for renaming the admin folder?

Share this post


Link to post
Share on other sites

 

I hope you don't mind me jumping on this thread with regards to 6.2 Installation problems. But

I did an update via ftp from 6.1.14 to 6.2 myself this morning with standard foundation skin, had green lights all the way through setup and installation, upon logging logging in to admin with new details, though nothing seems to have changed, checked that store overview said 6.2, it did.
Open store up to view and noticed home screen banners displayed all 4 images down the screen and not sliding effect, other error was top right basket link never worked and also on all product pages, the specification tab info was displaying information underneath product description, so the tab button not working as it should.

Got a panic on and managed to ftp 6.1.15 on instead, everything looks back to normal as in it seems to be working ok

Just checked upgrade logs: not sure if this was from 6.1.15 errors.

admin_****/skins/default/templates/products.coupons.php - Content after extract don't match source
admin_*****/skins/default/templates/main.php - Content after extract don't match source
admin_*****/skins/default/templates/settings.geo.php - Content after extract don't match source
admin_*****/skins/default/templates/customers.gdpr.php - Missing but expected after extract


Couple of system errors now as well.

    Today, 13:06     [Notice] /home/*****/public_html/admin_*****/sources/settings.index.inc.php:130 - Undefined index: path
    Today, 13:06     [Notice] /home/*****/public_html/classes/ssl.class.php:38 - Undefined index: _g
    Today, 13:05     [Notice] /home/*****/public_html/admin_*****/sources/dashboard.index.inc.php:380 - Undefined variable: smarty_data
    Check/Uncheck all     With Selected:


Will stick with 6.1.15 for now and see how things run over the next day or two.

Share this post


Link to post
Share on other sites
2 minutes ago, shaununouk said:

 

I hope you don't mind me jumping on this thread with regards to 6.2 Installation problems. But

I did an update via ftp from 6.1.14 to 6.2 myself this morning with standard foundation skin, had green lights all the way through setup and installation, upon logging logging in to admin with new details, though nothing seems to have changed, checked that store overview said 6.2, it did.
Open store up to view and noticed home screen banners displayed all 4 images down the screen and not sliding effect, other error was top right basket link never worked and also on all product pages, the specification tab info was displaying information underneath product description, so the tab button not working as it should.

Got a panic on and managed to ftp 6.1.15 on instead, everything looks back to normal as in it seems to be working ok

Just checked upgrade logs: not sure if this was from 6.1.15 errors.

admin_****/skins/default/templates/products.coupons.php - Content after extract don't match source
admin_*****/skins/default/templates/main.php - Content after extract don't match source
admin_*****/skins/default/templates/settings.geo.php - Content after extract don't match source
admin_*****/skins/default/templates/customers.gdpr.php - Missing but expected after extract


Couple of system errors now as well.

    Today, 13:06     [Notice] /home/*****/public_html/admin_*****/sources/settings.index.inc.php:130 - Undefined index: path
    Today, 13:06     [Notice] /home/*****/public_html/classes/ssl.class.php:38 - Undefined index: _g
    Today, 13:05     [Notice] /home/*****/public_html/admin_*****/sources/dashboard.index.inc.php:380 - Undefined variable: smarty_data
    Check/Uncheck all     With Selected:


Will stick with 6.1.15 for now and see how things run over the next day or two.

What a mess. You can't just upload 6.1.15 after upgrading to 6.2.0. I'd suggest restoring a backup (database & files) prior to any work you have done to day then follow the manual upgrade instructions.

3 minutes ago, shaununouk said:

Will stick with 6.1.15 for now and see how things run over the next day or two.

Bad plan. Your store is now at a mix of 6.2 and 6.1.15 you must restore a backup. 

Share this post


Link to post
Share on other sites

It's annoying and I'm sorry but the auto upgrade tool has had bugs and compatibility issues with some hosting environments. If you get errors as you did then it hasn't worked. 

In those circumstances you must upgrade manually as advised. 

Share this post


Link to post
Share on other sites

Did the upgrade after making a backup , via the cc panel,, it did not work out,

Upload by ftp and all is working as far as i can see.

 

Share this post


Link to post
Share on other sites

upgrade is easy.

backup your files and database (rename directory name).

log in to your phpmyadmin,rename the old tables.

install new cubecart version and then log in to your phpmyadmin,compare the differences between the new tables and old tables.

if the same,delete the new table and rename the old one.

if different,use the example SQL like below:

INSERT INTO CubeCart_inventory (product_id,status,product_code,...) SELECT product_id,status,product_code,... FROM oldCubeCart_inventory;

after above actions,install your extensions.

you may need to copy back the product images from the old files.

done

Share this post


Link to post
Share on other sites

As well as renaming the admin.php file and Admin directory, do you also have to modify the global file with the right names?

 

Thanks

Share this post


Link to post
Share on other sites

They have to match. Whatever names you choose, the values in the global.inc.php and the actual file and folder names must be the same. The admin script filename must, of course, end with .php.

Share this post


Link to post
Share on other sites
On 5/9/2018 at 1:55 AM, bsmither said:

They have to match. Whatever names you choose, the values in the global.inc.php and the actual file and folder names must be the same. The admin script filename must, of course, end with .php.

OK, but when you download the update, the file in the includes folder is global.inc.php-dist.  I updated this with the filename for admin.php and folder name for admin (after renaming file and folder to match the 6.1.15 version) and it seemed to work OK (GDPR tab is there, version number appears correct). 

Did I do this correctly?

Thanks

Share this post


Link to post
Share on other sites

There are more variables that just what holds vales for the admin script and admin folder. Be sure to copy over those values from CC6115. Then, I assume, you renamed globals.inc.php-dist to globals.inc.php.

This globals.inc.php-dist is an information file for you to know what information needs to be found and made ready.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×