Jump to content
Sign in to follow this  
DarwinUK

Intranet Server Issues

Recommended Posts

Hello Everyone.

Ive setup an old box as an intranet server running Ubuntu 18.04. Ive also installed lamp, php, mysql and mariadb. I next created a db for cubecart and was then able to install cubecart v6.

I can log into the cubecart admin page, setup store settings, add products, add payment plugin, surf the intranet shop, add products to cart by just clicking on "Add to cart" if a product is listed as a "Latest Product".

My problem is if I want to go in to the product and see a description, I get the following error page:

" The requested URL /shop/fanclub/fanclub-01.html was not found on this server.  Apache/2.4.29 (Ubuntu) Server at 192.168.1.131 Port 80"

Have i missed something, or would it be a problem with missing software from setting up Ubuntu ?

Thanks

Phillip

Share this post


Link to post
Share on other sites

Posted (edited)

CubeCart v6 relies on the "friendly URL" concept. As such, at some point that friendly URL needs to be rewritten or re-evaluated to some other format.

CubeCart relies on the web server's .htaccess extension directives having to do with URL Rewriting (mod_rewrite).

If the .htaccess file in CubeCart's main folder has rewriting directives, then the next step is to make sure the web server has config settings allowing for directives in the .htaccess file to override general web server settings. Please read the documentation for the web server regarding ALLOW OVERRIDES.

Edited by bsmither

Share this post


Link to post
Share on other sites

OK........

bsmither thanks for the reply, kind of helpful, was way over my head, but at least it pointed me in the right direction.

Did a google and the second link led me to https://stackoverflow.com/questions/18740419/how-to-set-allowoverride-all

I did the following :

Open Putty and log into Ubuntu Server

sudo nano /etc/apache2/apache2.conf

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>

and change it to;

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>

Save and exit file

sudo service apache2 restart

sudo a2enmod rewrite to enable module rewrite.

sudo systemctl restart apache2

Ive now retested my intranet site and it works now. So thank you, thats another piece of great info that I can add to my "Howto" guide.

 

Phillip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×