Jump to content
Sign in to follow this  
Ultim8pc

SMTP connection issues

Recommended Posts

Due to an ongoing hosting problem I've had to rebuild my site.
I now find that I cannot get email working.

Previously I had successfully used SMTP with TLS, port 587 and no authentication.
The same settings now no longer work and I get the following error when testing: 

Testing SMTP with TLS SERVER -> CLIENT: 220 smtp.livemail.co.uk ESMTP Postfix CLIENT -> SERVER: EHLO www.airevalleyclassics.co.uk SERVER -> CLIENT: 250-smtp.livemail.co.uk250-PIPELINING250-SIZE 51200000250-VRFY250-ETRN250-STARTTLS250-AUTH PLAIN LOGIN250-AUTH=PLAIN LOGIN250-ENHANCEDSTATUSCODES250-8BITMIME250 DSN CLIENT -> SERVER: STARTTLS SERVER -> CLIENT: 220 2.0.0 Ready to start TLS CLIENT -> SERVER: EHLO www.airevalleyclassics.co.uk SERVER -> CLIENT: 250-smtp.livemail.co.uk250-PIPELINING250-SIZE 51200000250-VRFY250-ETRN250-AUTH PLAIN LOGIN250-AUTH=PLAIN LOGIN250-ENHANCEDSTATUSCODES250-8BITMIME250 DSN CLIENT -> SERVER: MAIL FROM: SERVER -> CLIENT: 250 2.1.0 Ok CLIENT -> SERVER: RCPT TO: SERVER -> CLIENT: 553 5.7.1 : Sender address rejected: not logged in SMTP ERROR: RCPT TO command failed: 553 5.7.1 : Sender address rejected: not logged in CLIENT -> SERVER: QUIT SERVER -> CLIENT: 421 4.7.0 smtp.livemail.co.uk Error: too many errors SMTP ERROR: QUIT command failed: 421 4.7.0 smtp.livemail.co.uk Error: too many errors SMTP Error: The following recipients failed: [email protected]: : Sender address rejected: not logged in

I have tested that the email account I am using can successfully login to webmail. (same account as I used previously and successfully). I'm with Fasthosts and have opened a ticket with them to see if they can shed any light on it.

Any help appreciated.
 

Share this post


Link to post
Share on other sites

1 hour ago, Ultim8pc said:

Previously I had successfully used SMTP with TLS, port 587 and no authentication.

I have tested that the email account I am using can successfully login to webmail. (same account as I used previously and successfully).

Your previous hosting company allowed open relay SMTP connections with no authentication - WOW !  That will almost certainly be your problem as I do t know of any reputable company that would allow that !

If the password is working for webmail then the most likely cause is the lack of authentication so try that first.  Port 587 should be open but TLS connections can also sometimes be made via port 25

Ian

Share this post


Link to post
Share on other sites

Ian

Indeed, go figure..

To clarify, the settings I listed are those I used with Fasthosts previously, which worked and which they told me to use...
When I say previously.. Due to a severe performance issue, they moved my site to another server. Since then email hasn't worked.
I've tried all the usual combinations of configuration, SMTP with and without SSL/TLS, ports 465, 587 and 25 and auth on/off.
Been on with their tech support people today (who are pretty useless to be honest) and they haven't come to any conclusions.
I did wonder whether the server move may mean an issue between that server and their mail host which is stopping correct comms, such as firewall. Which I have suggested to them as something to look into.
To be honest I might sack them off as their ability to even understand an issue is now problematic and you have to lead them through it that much you might as well be doing it yourself.

I threw the question on here as a quick search showed lots of others seemingly posting issues where mail didn't work when configured correctly..

Cheers
 

Share this post


Link to post
Share on other sites

I can’t see any reason why they would allow the use of an open SMTP relay - along with a whole host of other issues, it is the quickest way to get the Server IP blacklisted.

What version of CubeCart are you running ?  Do the EXACT same settings work if you set up the same account in an email client such as outlook ?

Ian

Share this post


Link to post
Share on other sites

If i configure the settings provided by Fasthost  into Outlook and the email name and password it works..

Edited by Ultim8pc

Share this post


Link to post
Share on other sites

According to the conversation debug trace, there is no email address in the MAIL FROM: and also the RCPT TO: commands.

If you are using CC61*, be sure to save the settings before clicking the Test button.

If CC62*, the text entry fields are collected via javascript and an ajax call is made.

So, make sure there is a Sender's Email Address. It is this address used for the FROM and TO fields of the test email.

Edited by bsmither

Share this post


Link to post
Share on other sites

Bsmither
I'm using 6.2.1.

I have all fields correctly filled in the email config. Using a validated email account and password. Saving between any changes.
The same settings for the email account I am using, work in Outlook

SMTP with TLS, port 587, No auth 

 

 

SERVER -> CLIENT: 220 smtp.livemail.co.uk ESMTP Postfix
CLIENT -> SERVER: EHLO www.airevalleyclassics.co.uk
SERVER -> CLIENT: 250-smtp.livemail.co.uk250-PIPELINING250-SIZE 51200000250-VRFY250-ETRN250-STARTTLS250-AUTH PLAIN LOGIN250-AUTH=PLAIN LOGIN250-ENHANCEDSTATUSCODES250-8BITMIME250 DSN
CLIENT -> SERVER: STARTTLS
SERVER -> CLIENT: 220 2.0.0 Ready to start TLS
CLIENT -> SERVER: EHLO www.airevalleyclassics.co.uk
SERVER -> CLIENT: 250-smtp.livemail.co.uk250-PIPELINING250-SIZE 51200000250-VRFY250-ETRN250-AUTH PLAIN LOGIN250-AUTH=PLAIN LOGIN250-ENHANCEDSTATUSCODES250-8BITMIME250 DSN
CLIENT -> SERVER: MAIL FROM:<[email protected]>
SERVER -> CLIENT: 250 2.1.0 Ok
CLIENT -> SERVER: RCPT TO:<[email protected]>
SERVER -> CLIENT: 553 5.7.1 <[email protected]>: Sender address rejected: not logged in
SMTP ERROR: RCPT TO command failed: 553 5.7.1 <[email protected]>: Sender address rejected: not logged in
CLIENT -> SERVER: QUIT
SERVER -> CLIENT: 421 4.7.0 smtp.livemail.co.uk Error: too many errors
SMTP ERROR: QUIT command failed: 421 4.7.0 smtp.livemail.co.uk Error: too many errors
SMTP Error: The following recipients failed: [email protected]: <[email protected]>: Sender address rejected: not logged in

-----

 

smtp.jpg

Share this post


Link to post
Share on other sites

Please try to use Authentication.

I saw the first posting had no entry for MAIL FROM and RCPT TO. The above now has this. (The angles must have hidden them originally.)

But this says (also said earlier) that you are not logged in.

 

Share this post


Link to post
Share on other sites

You should always use Authentication (and still cant believe they are telling you to attempt to connect without it) but you do say that you tried various combinations with and without authentication.

Try changing the password so that it doesnt have any special characters in it - so only use letters (upper and lower) and numbers - I am pretty sure that this will "solve" the problem

Share this post


Link to post
Share on other sites

Havenswift,

Thanks for your suggestion.
I'd had similar thoughts to you, as the clue is that the log says 'not logged in'.
So I changed the password for the account using a simple password and confirmed it worked on my outlook client.
Then I changed the password on the email config and got the same failed result.

So I then used another working email account details in the email settings and that also fails in the same way.
It's almost as if the email account username and password are not being passed to the mailserver.
I'm stumped at this point.

Edited by Ultim8pc
Typos

Share this post


Link to post
Share on other sites

Pretty difficult to help much further with direct access to your site and server - your hosting company should be able to help here but you have said they are pretty useless although most hosting companies know nothing about your application.  We had a few clients where their emails suddenly stopped sending and in all cases it was where the SMTP authentication in CubeCart (webmail and email clients were still fine) was failing due to the password having a special character in it - used to work fine but now doesnt

Share this post


Link to post
Share on other sites

As an update, I resolved this after some time on the phone with the hosting provider. Seems they had an issue at their end which caused the spurious results.
All working as expected now using SSL.
Thanks for everyones input.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...