Jump to content
garywhitling

Unable to upload images via file manager

Recommended Posts

Hi,

I am having trouble uploading images via the file manager.

It was fine two days ago but now it has just stopped working.

I have asked my web host if they have made any changes and they say they have not so i am a bit stumped.

Any ideas of what i need to check?

Cheers Gary

Screen Shot 2018-07-30 at 20.25.10.png

Share this post


Link to post
Share on other sites

Just a guess...

In admin, Dashboard, Store Overview tab, (depending on the CC version), there will be a calculation of the sizes of the Image folder and Download folder (or a link to calculate it).

What's not given, however, is the max size each folder can accommodate. I am not sure where that is established.

So, the guess to verify is, has the folder contents consumed all allocated file space. (If there is, in fact, a limit.)

Share this post


Link to post
Share on other sites

Hi bsmither,

I have checked and the can see its 1.06 GB

I will check with my host but not aware of any limits. Would CubeCart impose any limits?

It's still possible to upload via FTP but not via file manager.

Just checked my logs and have got this

(70007)The timeout specified has expired: mod_fcgid: can't get data from http client, referer: https://www.REMOVED THIS PART FOR PRIVACY?_g=filemanager&subdir=sub-categories

Never had timeouts before ๐Ÿ˜ž
=====================================================

CubeCart Version
6.2.0
PHP Version (5.6 Recommended)
7.0.31
MySQL Version
5.1.73
Image folder size
1.06 GB
Download folder size
2.91 MB
Max. Upload filesize
40M
Browser user-agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1.2 Safari/605.1.15
Server Software
Apache

Share this post


Link to post
Share on other sites

If your browser has a diagnostics panel, such as a Network pane (as well as a Debugger pane and Console pane), then enable it. Request the admin, Images, Upload tab.

View the Network pane to make sure everything arrived (no 404's).

Drop an image onto the Drop-Zone. On the Network pane, watch to see what gets sent out by the browser, if anything. There should be a POST to _g=filemanager, followed by a GET to _g=filemanager. The POST payload will be the image.

If any javascript is missing or bad, the Console pane should show it.

Share this post


Link to post
Share on other sites

Hi bsmither,

Well I got the browser ready and dropped the images in the drop zone and they uploaded perfectly at lightning speed!

So its all ok now ๐Ÿ™‚

I am wondering if my host had some issues and now they are fixed ๐Ÿ˜‰ย 

Cheers for your help. If it happens again i will carry out the above to troubleshootย 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×