Jump to content
Nebojsa

Problem wit local specific characters on client (shop) side

Recommended Posts

As administrator all specific characters are present correct, when go on shop, instead show sign ? instead specific characters. I checked code page on MySQL, on ini.inc.PHP also set UTF-8.

on administrator side: Termostat bežični; on client side as shop show: Termostat be� i� 

Any idea what need setup.

 

Share this post


Link to post
Share on other sites

Two things we can look at: the language pack being used for the storefront, and the coding of the skin template.

Language pack: in the /language/ folder, examine the file of the language being used (Polish? Romanian?). Near the top, you will want to see something like:

<language version="2.0">
 <info>
...stuff...
   <character_set>utf-8</character_set>

If the character_set node is not there, we must then determine if the file is indeed utf-8, and if so, add the node. (Then clear CubeCart's cache.)

If the node is there, then...

Skin template: in the skin folder being used, examine the file main.php. Near the top, you will want to see something like:

<!DOCTYPE html>
<html class="no-js" xmlns="http://www.w3.org/1999/xhtml" dir="{$TEXT_DIRECTION}" lang="{$HTML_LANG}">
   <head>
      <title>{$META_TITLE}</title>
      <meta charset="{$CHARACTER_SET}">

or

<!DOCTYPE html>
<html class="no-js" xmlns="http://www.w3.org/1999/xhtml" dir="{$TEXT_DIRECTION}" lang="{$HTML_LANG}">
   <head>
      <title>{$META_TITLE}</title>
      {include file='templates/element.meta.php'}

If the second example, then in the file element.meta.php,

<meta charset="{$CHARACTER_SET}">

If the meta tag for charset is not there, it will need to be added.

What skin are you using?

Share this post


Link to post
Share on other sites

Thenks so much, I check all your sugestions and look everything is OK, exactly as you described. I using Croatian language (local name: Hrvatski)

Language file: hr-HR.XML

?xml version="1.0" encoding="UTF-8"?>
<language version="2.0">
 <info>
  <title>Hrvatski</title>
  <code>hr-HR</code>
  <character_set>utf-8</character_set>
  <version>1.0.0</version>
  <minVersion>5.0.0</minVersion>
  <maxVersion>6.*.*</maxVersion>
  <default_currency>HRK</default_currency>
  <text_direction>ltr</text_direction>
 </info>

Use Skin: Foundation. I check with other Skins, same problem appear.

Need tell you problems not exist during use CubeCart version 6.1.13

Appear when installed version 6.2.1, as well now use version 6.2.2.

 

 

 

Share this post


Link to post
Share on other sites

I believe you are developing your site on a local machine. Thus, you are not able to have the public access your site.

Where did you get the hr-HR.xml file?

Share this post


Link to post
Share on other sites
22 hours ago, bsmither said:

I believe you are developing your site on a local machine. Thus, you are not able to have the public access your site.

Where did you get the hr-HR.xml file?

I create hr-HR.XML adding new language and select appropriate language ISO codes hr-HR and currency.

After that made translation English to Croatian.

My Cubecart store is possible reach on: http://edserver.ddns.net/cubecart/index.php

I like tell again problem appear after upgrade version 6.2. with 6.1 all worked well.

Share this post


Link to post
Share on other sites

Really weird. In the link:

Example:

<a href="somethingplace" title="something">som� thing</a>

the href property is correct, the title property is correct, yet the inner text is malformed. The title property and the inner text uses the same Smarty variable.

Something new to CC6.2 is the "squeezing" of template output. Squeezing happens when the Smarty processor eliminates all unnecessary spaces, tabs, line endings, etc, and makes a few changes such as minifying color:#ffffff; to color:#fff;.

As an experiment, in admin, Store Settings, Advanced tab, enable debugging and enter your IP address in the adjacent text entry field (www.whatismyip.com). Then, clear CubeCart's cache.

CC622 has implemented a bypass on the squeezing/minifying when in debug mode.

If the problem disappears, then we will look closely at the new squeezing module.

Share this post


Link to post
Share on other sites
18 hours ago, bsmither said:

Really weird. In the link:

Example:

<a href="somethingplace" title="something">som� thing</a>

the href property is correct, the title property is correct, yet the inner text is malformed. The title property and the inner text uses the same Smarty variable.

Something new to CC6.2 is the "squeezing" of template output. Squeezing happens when the Smarty processor eliminates all unnecessary spaces, tabs, line endings, etc, and makes a few changes such as minifying color:#ffffff; to color:#fff;.

As an experiment, in admin, Store Settings, Advanced tab, enable debugging and enter your IP address in the adjacent text entry field (www.whatismyip.com). Then, clear CubeCart's cache.

CC622 has implemented a bypass on the squeezing/minifying when in debug mode.

If the problem disappears, then we will look closely at the new squeezing module.

I made this experiment and problem disappear. Now all specific characters in store show correct.

Share this post


Link to post
Share on other sites

So far, I am unable to get the squeezer to malfunction.

I have manually added product details matching what you have, but those details are being shown correctly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×