Jump to content
Antonw.com

Images are not visible in the file list

Recommended Posts

After I migrated my shop (latest version) to another host the images I upload when creating a new product does not
get set as images/thumbnails for the product and the images not show in the file list/picker file.
They do show in the file list when I go into admin - Images and Update File List.

Does anyone know what it might be problem with the images not showing in the file list when creating the a new product?

Thanks for any advises!

Edited by Antonw.com

Share this post


Link to post
Share on other sites

We have same issue just happened these days starting not showing images list when I try to edit images in products page, don't know specific reason all the sudden changed since it didn't happen before

011419-01.jpg

Share this post


Link to post
Share on other sites

We will start by asking how many images are in the /images/source/ folder.

Share this post


Link to post
Share on other sites

This could be the cause -- PHP is running out of time to create the list for the FilePicker.

In admin, PHP Info, scroll to the Core table and find "max_execution_time". It will probably be 30 in the middle column.

Please create the error log (https://forums.cubecart.com/topic/51550-how-to-create-the-error-log/). This will also change how much time PHP is allowed to run to 60 seconds. If this still doesn't get you a list, try increasing the timeout value.

Then, when you have free time, in admin, Images, start moving files into subfolders.

Edited by bsmither

Share this post


Link to post
Share on other sites

It's still not working after increasing the time to "60", but I got some information from error-log page as below

[15-Jan-2019 12:48:36 America/New_York] PHP Notice:  Error: Hook 'directory/hooks/admin.product.pre_display.php' was not found in /home/epochhat/public_html/shop/classes/hookloader.class.php on line 288
[15-Jan-2019 12:48:37 America/New_York] PHP Notice:  Error: Hook 'directory/hooks/admin.navigation.php' was not found in /home/epochhat/public_html/shop/classes/hookloader.class.php on line 288

Share this post


Link to post
Share on other sites

Those errors suggest that a plugin named directory was physically removed from the site, but was not removed via admin, Manage Extensions.

Share this post


Link to post
Share on other sites

Thanks bsmither, tried to do everything, no lucky for image list problem, maybe somewhere we did wrong not even knowing since it worked before.

Share this post


Link to post
Share on other sites

There is a Developer Tools Suite in the (Firefox and most other) browsers, which can be used to show the ALAX request to your store for the list.

The Network tab of the Tools will show what was requested and what was returned -- if anything.

Since we are not seeing an error message logged saying that PHP ran out of time, we might want to start looking elsewhere for the missing list of images.

Share this post


Link to post
Share on other sites

Just for the updates, luckily, we got the image list back today without doing anything, it's still mystery how it was disappeared and then coming back.

Hopefully one day we can find the reason.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×