Jump to content
detectorman

ioncube update errors

Recommended Posts

Hi All,

Cubecart 6.2.2
I have updated server php from 5.6 to 7.2
Admin login now fails with ioncube PHP loader error so I ran the loader wizard and followed instructions to install new version (7.2)
Now when trying to  open admin page I get an error 500.

php.ini is installed in home directory and ioncube folder namely:
zend_extension=/kunden/homepages/16/d87654321/htdocs/folder_name/ioncube/ioncube_loader_lin_7.2.so

Any suggestions would be most welcome.

Dave

 

Share this post


Link to post
Share on other sites

Perhaps it is the case that for PHP 7.2, one needs to update the ionCube loader (which you have done), and also to have the author(s) of encoded module(s) issue updated version(s) that have been encoded for that version of the loader.

Share this post


Link to post
Share on other sites

Thanks bsmither for that quick response. Web page opens OK and unfortunately, as I cannot login to admin, I cannot disable modules.
I am tempted to roll back to PHP 5.6 but 1&1 are withdrawing support for this at the end of the month.

Dave

 

Share this post


Link to post
Share on other sites

If you change what version of PHP your account uses (and it is a very good idea to move from PHP 5.6 and go to PHP 7.2 both for security and speed) then you will also need to get PHP 7.2 encoded versions of any plugins you are using.

Ensure you download 7.2 encoded versions of all encoded plugins

Switch your hosting account to PHP 7.2

Use FTP or other file upload method to overwrite the PHP 5.6 encoded versions of the plugins with the newly download 7.2 versions

Ian

Share this post


Link to post
Share on other sites

Thank you both for your help.
I disabled all plugins and switched to PHP 7.2. I then switched on each plugin and found that the problem seems to lie with the Multi Level Shipping module.

I updated this from v1.03 to v1.04 but problems remained. Subsequently reverted to all-in-one v1.03 and PHP 5.6.

Now everything seems to work (checkout etc). but I am not sure how to check compatibility of my plugins.

Barclaycard / Paypal / Multi Level Shipping  / Crafty Clicks / Print Order Form...and that's it.

Dave

Share this post


Link to post
Share on other sites
33 minutes ago, detectorman said:

I then switched on each plugin and found that the problem seems to lie with the Multi Level Shipping module.

That might be the first one you came across but any purchased from @Noodleman or from us would be encoded and all would need to be replaced

33 minutes ago, detectorman said:

I updated this from v1.03 to v1.04 but problems remained. Subsequently reverted to all-in-one v1.03 and PHP 5.6.

It isnt the version of the plugin that is important but which PHP version the files have been encoded for.  Unfortunately @Noodleman hasnt updated the marketplace with recent versions and the PHP 5.6 and above version available there wont work.  Get the PHP 7.2 version instead from https://www.noodleman.co.uk/downloads.html#multilevel_shipping

Share this post


Link to post
Share on other sites

Thank you once again for your help.

YES.....Uploaded PHP 7.2 version of Multi Level Shipping, updated server to PHP7.2 and no more errors.

(hopefully)

Thanks again

Dave

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...