Jump to content
JerS

No Cubecart upgrade with PHP 7.1 or above

Recommended Posts

Hi,

A question..
I have two Cubecart stores.
Both version 6.2.2 (latest release).

One store runs perfectly on PHP 7.2 as advised by Cubecart upgrade setup.
The other Cubecart goes down with PHP above 7.0


Both sites are at the same hosting and placed at the same server also.

Once a month there is an update on the server site updating PHP to 7.2
And every month (the last couple of months..) the Cubecart store goes down.


Maybe there is something I can do? Manual perhaps. To make Cubecart compatible with PHP 7.2?

Hope someone can help me out.
Jeroen

 

 

Share this post


Link to post
Share on other sites

Firstly your hosting company should not really be automatically upgrading your PHP version due to issues like this but if you are running on 7.0 or below and they intend to remove support for this and 5.6 which are both out of security support, then this might be their way of prompting you to sort your website out to make it compatible.

CubeCart runs perfectly under 7.2 so it is likely that the store that crashes has an ionCube encoded plugin which the other store doesn’t. You need to get a php 7.2 encoded version of all encoded plugins, do the php upgrade yourself and use ftp to upload the new versions of your plugins

Ian

Share this post


Link to post
Share on other sites

it's probably a module, encoded for an earlier version of PHP, list the modules you have installed that are not free/supplied by CubeCart directly.

Share this post


Link to post
Share on other sites
On 1/19/2019 at 11:46 AM, havenswift-hosting said:

Firstly your hosting company should not really be automatically upgrading your PHP version due to issues like this but if you are running on 7.0 or below and they intend to remove support for this and 5.6 which are both out of security support, then this might be their way of prompting you to sort your website out to make it compatible.

CubeCart runs perfectly under 7.2 so it is likely that the store that crashes has an ionCube encoded plugin which the other store doesn’t. You need to get a php 7.2 encoded version of all encoded plugins, do the php upgrade yourself and use ftp to upload the new versions of your plugins

Ian

Hi Ian,
Thanks I will check the plugins.
 

 

Share this post


Link to post
Share on other sites
23 hours ago, Noodleman said:

it's probably a module, encoded for an earlier version of PHP, list the modules you have installed that are not free/supplied by CubeCart directly.

Most of the plugins are the same... but not all of them.

And I learned so much today! Thanks ...

**** ALWAYS check all your plugins. ****

Most of the plugins are the same... but not all of them.
And I learned so much today! Thanks ... ALWAYS check the plugins.
It was Product Rollover images. I used the 1.4 version instead of the 1.5 - from Havenswift Hosting  :)
And… I installed it some time ago for PHP 5.6
After setting the PHP to PHP 7.2 via Cpanel and Product Rollover images 1.5 for PHP 7.2…
All works perfect!
Plugins sometimes give an update message when there is a new version as from 1.4 to 1.5
Well.. maybe missed it. Sure could be... sorry.
But installing the working PHP version was absolutely up to me :)
Thank you very much for your time!

Have a nive Sunday!

 

Edited by JerS
Spellcheck..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×