Jump to content
Sign in to follow this  
webspinning

Digital downloads

Recommended Posts

I am setting up a new digital video download site.  All going well and working fine until I try to enable the content from a mobile device.

Tried adding a custom file path to the actual MP4 and I don't have access to download - which I think is fine.

Anyone got any ideas on how to enable MP4 if the link in the order confirmation is clicked from a mobile device please?

Share this post


Link to post
Share on other sites

"enable the content"?

Do you mean to say that when clicking the link (it has an accesskey part to the querystring), you get a different response from your store from a desktop versus a mobile web browser?

Share this post


Link to post
Share on other sites

Please verify the link looks identical between the desktop browser versus the mobile browser.

And, what is the actual response on the mobile browser after having clicked the link?

I just set my desktop browser to "lie" and claim it is an iPhone5. The link is the same as before, and clicking it started the download of the PDF file I have associated with the product related tot he link.

That is to say, I was not able to reproduce your observation. (Granted, I did not use an actual mobile device.) But as far as CubeCart is concerned, having a User Agent string saying the browser is a 'mobile' browser, did not change how the file was to be sent out onto the Internet.

Share this post


Link to post
Share on other sites

It is the same link, I am opening it from the same email and on my PC it is fine but not so on my mobile or iPad.  I think I have a work around, a bit more time needed to solve but I will update on here either way.  Thanks for your help thus far.  Appreciated.

Share this post


Link to post
Share on other sites

What is the actual response on the mobile browser after having clicked the link? What does the browser complain about?

Share this post


Link to post
Share on other sites

I told my browser to say it is an iPhone5 and I was able to download it - twice, in fact.

Share this post


Link to post
Share on other sites

An internet  search for slash through play button iphone has some relevant results. Something to do with your phone's operating system not having the appropriate video decoder (Flash?).

Share this post


Link to post
Share on other sites

More testing this morning and some interesting results.

Place the MP4 files for download in the secure 'File' folder tick the check box for the file location
Purchase MP4 from the shop
Select the link from the Purchasers email: 
  from mobile device - image as above - nothing plays.
  from PC file downloaded to download folder and can be played from here.

Place the MP4 files for download in the non secure 'Public' folder and enter the link in the custom file path
Purchase MP4 from the shop
Select the link from the Purchasers email: 
  from mobile device - MP4 plays.
  from PC - MP4 plays.

Obviously from the public directory the link is available to be found/copied etc so not an ideal location but I get the result I need.  How can I get this result from the secure 'File' folder please?

Edited by webspinning

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...