Jump to content
Sign in to follow this  
Masie

Foundation Skin Problems - CC6 Not Display Any CSS

Recommended Posts

Hi

I'm new to the forums.  I recently got a trial of a new skin Retail Therapy, but since installing it I can no longer use the foundation skin for CC6, it renders html, but no CSS.  I have asked the developer of the Retail Therpay skin for help, but they say they can't see any issues at their end. 

So this is what is happening over and over again: when I change the skin in admin from Retail Therapy to cubecarts foundation skin the website renders with html, but no CSS.  I try to change the skin back to Retail Therapy and it won't go back, so I'm stuck with a website that doen't work.  A few hours later I am able to change back to the Retail Therapy skin, but again when I see if I can switch between the skins again I just get the foundation skin rendering with no CSS, and I can't change back to Retail Therapy again.  I don't know a lot about website or cubecart, so if you reply can you explain each step I need to take to resolve this please, just think of me as being a six year old, that should do it lol! 

I have attached a image showing the problems I'm having.

Thank you for your help.

Capture cubecart foundation time 12.06 pm on 23rd Feb(FILEminimizer).jpg

Share this post


Link to post
Share on other sites

Welcome Masie! Glad to see you made it to the forums.

In admin, at the upper-right corner, after saving all the changes, if there is a lit button that says "Clear Cache", be sure to click on it. I mention this in case you aren't doing so already.

In Firefox, pres the keyboard shortcut CTRL-SHIFT-Q. This opens the Developer Tools Network panel.

Then, reload the storefront page with CTRL-F5. The Network tab will show everything that gets requested and returned.

You will be looking for any line that has a 404 in the status column.

Share this post


Link to post
Share on other sites

I had the same problem today Masie.

Mine caused by me clearing the cache AND the SQL cache in Maintenance

Suddenly the same visual error you get and only with the Foundation skin.

Did the above checks and found js files missing (404) for the foundation skin.

Although they were there in the cache folder they where shortened file names for some reason (?).

I think a string of numbers is added to the filename somehow which were missing so returned a 404 result.

I tried everything I could think of to no avail.

Finally, in desperation I cleared the cookies stored for the site iin Firefox and lo and behold it's fixed.

Hope that works for you.

 

 

Share this post


Link to post
Share on other sites

Hi bsmither

Thank you for that lovely warm welcome.  I'm not good at this and I kept pressing shift 5 instead of F5!  I didn't eventually got there, and yes there are some 404 errors.  I've taken snippets of them so you can see what I found.  I have no idea what I'm looking at! 

The snippet files are too big to upload, so I'll see if I can make them smaller.  I tried using Fileminimiser to make the snippets smaller, it worked, but I uploaded the wrong snippets and now I can't upload anything, even though I deleted those I uploaded.  Sorry I don't know how this works!

Thank you for your help.

Share this post


Link to post
Share on other sites

Hi kooby

Thank you for your suggestion.  I tried it, but it didn't work for me. 

I've been trying to setup a website for years and I just never manage to get things working and then give up.  I've tried with cubecart, prestashop and wordpress, but I keep coming back to cubecart.  I like cubecart the best.  This is my last attempt, if I fail this time, that's it, I've been doing this on and off since 2009! 

I am determined not to give up though, its so hard when you run into problems and can't work out what to do.  I even tried to learn html at Codecadamy, I can put a one page website together now with links and pictures, but when it comes to e commerce I'm lost.

 

 

Share this post


Link to post
Share on other sites

Hi Masie,

I spoke too soon. Fault came back, just vertical icons like yours and I've persevered and see how I can clear it and then bring it back on, and it is only with the Foundation skin.

I have just updated PHP to 7.2 (trying different versions) which has memcache  enabled.

My sequence goes like this:

With the problem showing I disable caching (memcache) under Store settings|Advanced
I then use the clear cache button at the top right  in Dashboard
(At that point it still has the problem if you try so I have to start again)
I then go into Firefox options and Privacy & Security to get at Manage data under Cookies so that I can clear the cookies for this site
Cntrl + F5 in Firefox refreshes the site and the fault is gone

       BUT

In dashboard I get a warning that the cache is disabled under Advanced and please enable it. and as soon as I do the storefront display fault is back

Very frustrating

I agree I like the general robustness and well thought out design of cubecart

I hope you persevere and get somewhere as its so satisfying when it works !

When checking in web developer - Network did you get any 404 prompts for foundation files like I did?


 

Share this post


Link to post
Share on other sites

Hi kooby

Yes I had 3 404 errors, but I haven't had a chance to look at them yet.  You could use a different skin for now, I'm using Retail Therapy and it works well, its so different from cubecarts default skin too.  Even though I'm using Retail Therapy I still want the foundation skin to work.  I haven't tried bsmither's second suggestions yet though.  I do agree that cubecart is great when its working. 

This is a new website for me, and I'm having some very strange problems, SEO is strange, the sub-category is appearing before the main category.

So  instead of:

dream-catchers/mini-dream-catchers

I get:

mini-dream-catchers/dream-catchers

The SEO path is the wrong way around.

The other thing that is not working for me is that I only have products in a single category, but they are appearing on all the categories and sub-categories that are empty as well! 

 

 

Edited by Masie

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...