Jump to content
Sign in to follow this  
dchurch

Admin Images not displaying

Recommended Posts

Hi, I just building my first Cubecart store. I have uploaded 6 images just fine. They all show up in when I select my product but just the first one that I uploaded displays next to the library box. And that box seems to be frozen (I cant check boxes...). Plus when I select "Images" from the document area I just get a blank white screen. I'm wondering if I should just delete this database and try a new installation. Or is this something easy to fix.

 

Thanks

Dave

Frozen Box.jpg

Share this post


Link to post
Share on other sites

Thank you,

I did a cut and paste into NotePad then change the file name as per instructions. Then uploaded that file into the web home directory via cPanel.

The file is there but I do not see a generated error file... I double checked the contents of the file named:  ini-custom.inc.php 

 

                               HomeDirectory.jpg.ca84e462d40cddeb90e527a4f5a77389.jpg

 

Share this post


Link to post
Share on other sites
Posted (edited)

I do have red "660" System Error Logs at Cubecart under the Advanced tab.

There are none showing at Admin Error Log

 

 

 

Errors_Pg1.jpg

Edited by dchurch
attached error log info

Share this post


Link to post
Share on other sites

There are now 730 System Error Messages. About 90% look like this:

Today, 05:02

File: [controller.admin.pre_session.inc.php] Line: [24] "SET @@time_zone = 'Europe/London'" - Unknown or incorrect time zone: 'Europe/London'

 

The other 10% look like this:

Today, 04:48 [Exception] /home/dbombmut/public_html/store/classes/filemanager.class.php:899 - Call to protected Catalogue::__construct() from context 'FileManager'

 

I don't see any other unique error messages.

 

Regards,
Dave

 

 

Share this post


Link to post
Share on other sites

This was covered yesterday and means that your hosting isn’t fully compatible with this latest version of CubeCart, specifically the MySQL server doesn’t have time zone name / offset table setup.  This is not something you can do as only the server administrator has access to be able to create and maintain this

All of our servers have this setup as standard

Ian

Share this post


Link to post
Share on other sites
Posted (edited)

In the file /controllers/controller.index.inc.php, near line 25:

Change:
$GLOBALS['db']->misc("SET @@time_zone = '".$GLOBALS['config']->get('config', 'time_zone')."'");

To:
// $GLOBALS['db']->misc("SET @@time_zone = '".$GLOBALS['config']->get('config', 'time_zone')."'");

Do the same to /controllers/controller.admin.pre_session.inc.php, near line 24.

The other error is interesting. I will look into it.

You will want to put the file ini-custom.inc.php in same folder as where CubeCart is installed. For you, that would be the folder /public_html/store/.

Let's also make sure of one other thing.

In the file /public_html/store/.htaccess , verify that these directives exist, and that the RewriteBase is actually /store/:

<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteBase /store/

 

And what is the exact version of PHP you are using? You can see this in admin, PHP Info.

Edited by bsmither

Share this post


Link to post
Share on other sites

I am going to make a wild guess. This may not work (as I have not installed CC623 as yet).

In /classes/filemanager.class.php, near line 899:

Find:

$catalogue = new Catalogue();

Change to:

$catalogue = $GLOBALS['catalogue']->getInstance();

If this does not stop that particular error message, then it didn't work. If it does, then this may also fix the missing list of images in the admin Image Picker.

Share this post


Link to post
Share on other sites

Thank you very much.

At this point I don't have much time invested in setting up my Cubcart  6.2.3 store.  I am wondering if I should just delete the database and install an older version for example "CubeCart 6.2.2 Released - Security Update". 

FastComet is the host. I simply followed installation instructions at their website and quickly found the image issue. The instructions mentioned version 6.0 but recommended downloading the "latest version".

 

Would version CubeCart 6.2.2 be more likely to work without issues at FastComet, or can you recommend another good version?

If so can you also recommend instructions for deleting and reinstalling?


I could upgrade to a newer CubeCart version in the future.


Thank you for your help,
Dave

Share this post


Link to post
Share on other sites

Hi

If you want / need to stay with FastComet for your hosting then what you should do is upgrade to 6.2.4 

and also ask them to install the MySQL timezone / offset tables on that server.

Alternatively, there are better hosting companies available 😀

Ian

Share this post


Link to post
Share on other sites

To follow up on this,

I contacted FastComet support and spent a little time trying to figure out the problem, and looked at a few other shopping carts...

But aside from the problem I was having I did like CubeCart so decided to just download CubeCart 6.2.4 and install a new Database...

 

The new version appears to be working perfectly!

 

So if you have a similar problem a reinstall may be a quick and simple solution.

Regards,

Dave

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...