Jump to content
Sign in to follow this  
Frank Auffret

All in One Shipping Actions not working

Recommended Posts

On one of my sites the All in One Shipping Actions buttons are not working so rates etc cannot be edited or deleted.
The Add New Shipping Rates link is working.
The version is 6.2.4

As a work-around I edited the prices in the DB table  but need to solve this.

Other sites on the same server are unaffected.

Share this post


Link to post
Share on other sites

To confirm, when viewing a Shipping Zone tab, clicking the Edit icon on a row of the shipping rates table does not cause the textual data in that row to be replaced with text entry fields containing that data?

This action is javascript controlled. The first thing to try is to force your browser to reload page resources (images, javascript, css). This is usually done with CTRL-F5 (but there is great difficulty in getting your mobile device's web browser to do this).

If fetching fresh copies of the module's javascript does not fix this, we will use the browser's developer tools to watch the Console when clicking the Edit button. If the javascript has attached an event monitor to the button, and is registering the click, but faults in some way, the Console will report the error.

For each row in the shipping rate table, each textual data item can also be clicked on to switch just that data item to a text entry field containing that data. Does clicking directly on the data item to be changed do anything?

Share this post


Link to post
Share on other sites
15 hours ago, bsmither said:

To confirm, when viewing a Shipping Zone tab, clicking the Edit icon on a row of the shipping rates table does not cause the textual data in that row to be replaced with text entry fields containing that data?

Yes that's correct click any of the 3 icons nothing happens

15 hours ago, bsmither said:

This action is javascript controlled. The first thing to try is to force your browser to reload page resources (images, javascript, css). This is usually done with CTRL-F5 (but there is great difficulty in getting your mobile device's web browser to do this).

Tried that also tried different browser 

15 hours ago, bsmither said:

If fetching fresh copies of the module's javascript does not fix this, we will use the browser's developer tools to watch the Console when clicking the Edit button. If the javascript has attached an event monitor to the button, and is registering the click, but faults in some way, the Console will report the error.

Nothing shows in console

15 hours ago, bsmither said:

For each row in the shipping rate table, each textual data item can also be clicked on to switch just that data item to a text entry field containing that data. Does clicking directly on the data item to be changed do anything?

Rolling the mouse pointer over the icons changes to hand indicating a link [edit row] 

I have re-uploaded the CC files - still nothing

Share this post


Link to post
Share on other sites
Posted (edited)

Fixed
I deleted a left over All-in-one-shipping file in /js/plugins/ and re-installed the latest version.

The site is quite old and been through many upgrades since starting from version 4

There's still a few issues with various functions so am thinking of deleting the files and starting again.

Is there a right and wrong way to go about that process?

Edited by Frank Auffret

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...