Jump to content
Sign in to follow this  
scythe000

6.2.0 White screen issue

Recommended Posts

When I try to do an upgrade, or file backup, it just goes to a white screen and stalls out. Any idea how to fix?

Share this post


Link to post
Share on other sites

Check the PHP error_log which will probably show the cause but it is likely that the process is reaching a php limit such as memory or more likely process time

Share this post


Link to post
Share on other sites

Interesting. The Zlib set of functions is standard in PHP - meaning they typically do not need to distinctly enabled.

If GoDaddy gives you a hosting control panel, and in that panel you can make adjustments to what language will run scripts, see if there is a list of optional PHP extensions that need to be enabled.

Make sure ZipArchive is enabled, as well as Multi-Byte.

(You may need to get GoDaddy's assistance in learning where and how to make this hosting environment change.)

Share this post


Link to post
Share on other sites

ok, got the Zip option set in CPanel.

Now, if i change the language to English (US), and click next, the page refreshes, nothing happens, and  I get this in the log:

File: [controller.index.inc.php] Line: [27] "SET @@time_zone = 'America/Los_Angeles'" - Unknown or incorrect time zone: 'America/Los_Angeles'

File: [controller.index.inc.php] Line: [27] "SET @@time_zone = 'America/Los_Angeles'" - Unknown or incorrect time zone: 'America/Los_Angeles'

If I leave it at English UK, I get this error:

 	File: [catalogue.class.php] Line: [70] "SELECT SQL_CALC_FOUND_ROWS MIN(`live_from`) AS `next_time` FROM `CubeCart_inventory` WHERE `live_from` > UNIX_TIMESTAMP() LIMIT 1;" - Unknown column 'live_from' in 'field list'

 

Crap I'm getting tons of those errors now for some reason

Share this post


Link to post
Share on other sites

The first error is a known issue. The solution is to have your hosting provider load a database system table with timezone information. This must be done by a server system administrator - database system tables are not to be managed by users.

The second error suggests that you are running CubeCart code of a recent version, but the database schema has not been updated to that same version.

Share this post


Link to post
Share on other sites

In admin, there will be an announcement saying the database is not at the level of CubeCart code -- if that is indeed the case. In admin, Maintenance, Upgrade tab, there will be a list of the (database schema) versions installed and when that upgrade to that version happened.

So, make sure that a code base version and database schema version mismatch actually exists.

You will need to put in place the /setup/ folder of the matching codebase version that is currently installed. Then run www.mystore.com/setup/index.php

 

Share this post


Link to post
Share on other sites

There must be a mismatch. It seems to think I'm on 6.2.0-b1, but the upgrade tab says I'm on the latest version

Share this post


Link to post
Share on other sites

"What" says you are on CC620b1?

In admin, Dashboard, Store Overview tab, what does "CubeCart Version" say?

 

Ok, just got the forum conversation update. You say now all is good?

Share this post


Link to post
Share on other sites

Yeah, seems that way. The upgrade tab says I'm on 6.2.5, and I used the backup utility to make a file and db backup.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...