Jump to content
Sign in to follow this  

Manually inserted option attributes were deleted. Why?

Recommended Posts


I cannot figure out what happened to some additional option attributes that I inserted manually using phpMyAdmin, and which seems having been deleted by CubeCart v. 6.2.5.

It is obvious that the option attibutes are stored in table "_option_value".

I have an option group named "Keys" to which individual keys "A", "B", "C", ..., "Z", ... were attached as option attributes.
From these attributes, I have option sets (=subsets of option attributes) that define the keys present in miscellaneous keyboard layouts.
For instance, a "QWERTY UK" and a "QWERTZ DE" option sets.

I tried appending new option attributes (e.g. the keys "Γ", "Ψ", "Λ", "Π", ...) so that I could create new keyboard layouts like the Greek one as new option sets.

I first did this through CubeCart's admin and this was kind of a nightmare* because the appended attributes got the first priority levels. However, the appended option attributes were stored durably.
(*more details here: https://forums.cubecart.com/topic/55093-option-attributes-badly-sorted-after-adding-more-options/)

To avoid the wrong priority issue, I then chose inserting the new attributes directly into the "_option_value" table by using phpMyAdmin.
I made sure that every new record had a unique (autoincremented) "value_id" and a unique "priority" level.
This was the case and I can confirm that the "_option_value" table was perfect.

Then I went into CubeCart admin.
The listed option attributes were still only those that were inserted with CubeCart.

So, I tried clearing all caches in "Administration maintenance", also cleared the browser cache and restarted the brower.

The option attributes that had been inserted manually with phpMyAdmin are away. I mean deleted and no longer present in the database table.
I have not done any further edition in CubeCart, appart maybe from deleting some incomplete "Greek keys" option set as I still had more records (Keys) to insert into the database.

I is like if CubeCart used some cached version of the database table that overwrote existing database table.

I already had observed this deletion of records, but the first time I couldn't believe it.

Any explanation?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...