Jump to content
Lincon

Getting too many redirects on cart

Recommended Posts

Posted (edited)

Hello everyone,,

Having a strange problem with our site in the past few days where the cart is really playing up, we're getting people having "too many redirects" errors when adding multiple items to the cart, its not showing the correct items in the cart, not able to remove products from the cart etc.. rest of the site seems fine apart from the carts.. 

I switched debug on and this error is at the top.. reversephonelookup.onl/ curated.onl/nba-reddit/

[Notice] /home/demonpai/public_html/classes/catalogue.class.php:446 - Undefined variable: selected[Notice] /home/demonpai/public_html/classes/catalogue.class.php:446 - Undefined variable: selected[Notice] /home/demonpai/public_html/classes/catalogue.class.php:446 - Undefined variable: selected[Notice] /home/demonpai/public_html/classes/catalogue.class.php:446 - Undefined variable: selected[Notice] /home/demonpai/public_html/classes/catalogue.class.php:446 - Undefined variable: selected[Notice] /home/demonpai/public_html/classes/catalogue.class.php:1100 - Undefined index: contents

Any ideas what the problem could be, or has anyone else experienced this?

The site is running on PHP version v5.4.45, mysql is v5.0.1

Edited by Lincon

Share this post


Link to post
Share on other sites

On 8/21/2019 at 6:23 PM, Lincon said:

Having a strange problem with our site in the past few days where the cart is really playing up, we're getting people having "too many redirects" errors when adding multiple items to the cart, its not showing the correct items in the cart, not able to remove products from the cart etc.. rest of the site seems fine apart from the carts.. 

This is likely to be a problem with sessions - check your session management to make sure you can save session files and permissions are correct. Also check that your domain cookie setting in CubeCart is correct

 

On 8/21/2019 at 6:23 PM, Lincon said:

I switched debug on and this error is at the top.. 

Those are just notices and will not affect any functionality

On 8/21/2019 at 6:23 PM, Lincon said:

The site is running on PHP version v5.4.45, mysql is v5.0.1

Ouch and Ouch again - old and massively old version ! Speak to your hosting company about about putting your hosting onto safe, secure versions that are not many years out of support - or move hosting company if they are unwilling

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...