Jump to content

PayPal Commerce


CubeCart Bot
 Share

Recommended Posts

9 minutes ago, vidmarc said:

Is the version of OpenSSL something I can configure in my hosting company's control panel? Which version does it need to be?

Very confusing for sure. Perhaps the PHP woprkaround is the way to go for now?

If you have an issue with the integration and you don't use plesk it's something else.

Link to comment
Share on other sites

It's a randon problem, not happening all the time. Would the complete log be of any use to you?

Quote

 

Request Sent (cURL) - https://api.paypal.com/v1/notifications/verify-webhook-signature

Error: cURL Error (22): The requested URL returned error: 400 Bad Request

Response received (400 - Bad Request)

 

 
Edited by vidmarc
Link to comment
Share on other sites

I guess it must be one of these?

3D Secure not required for the buyer or the card network did not require 3D Secure.  
An error occurred with the 3DS authentication system.  
Buyer was presented the 3D Secure challenge but chose to skip the authentication.  
Buyer may have failed the challenge or the device was not verified.  
3D Secure was skipped as authentication system did not require a challenge.  
Card is not enrolled in 3D Secure as card issuing bank is not participating in 3D Secure.  
Issuing bank is not able to complete authentication.  
Card is not eligible for 3DS Secure authentication.
Link to comment
Share on other sites

Hi,

I'm having an issue were as payment is never received.  I can place an order just fine, it goes through the whole process, I logon to paypal and pay - however, I am then returned back to my account page and it says pending.   When I logon to the store, the order comes through as it should, it is 'pending' .  I logon to my paypal account and no money has been taken out - I logon to the store paypal account and no money has gone in?

I thought maybe I need to change the status of the order, so I made it processing, then complete.  Emails go out to the buyer, but again, no money changes hands?   I've tried disconnecting from the paypal account and removing extension, reinstalling, reconnecting, clearing all caches and tried again - but with same result.

would anyone be able to help please?

Link to comment
Share on other sites

  • 1 month later...
8 minutes ago, Al Brookbanks said:

We can't do that as the integration is built to PayPal certification.

Understand that but there are a LOT of people that dont like being forced to have certain aspects like the express button (or simply cant for very valid business reasons) and will never upgrade to this plugin while this is in place.  This is going to lead to a LOT of sites running the old unsupported PayPal plugins and if they break at some stage in the future, then some have already said they would consider stopping using CubeCart and move to a different package which is not somebody that any of us want !

Link to comment
Share on other sites

  • 2 weeks later...

After a few emails back and forth with the Paypal techie guys, i've about drawn a blank

 

He states:

The module should allow you to turn express on and off?

Unfortunately we have no oversight on the development of the plugins or their functionality. I can advise on the code if that’s of any help, but normally the plugins are developed by third party developers.  

 

I'm agreed on the conversions, if truth be known Express saves the customer a few steps.

However, It doesn't work for everyone (me for a start)

Link to comment
Share on other sites

39 minutes ago, fabriceunko said:

Hello, I have several customers indicating to me that they have prepared their cart, when they click on the payment page nothing is displayed. The page remains blank. He knows the page where the bank card number is indicated

Same here. Even if they try on other devices. Just one of many issues with this plugin.

 

iDeal is still not solved either (doesn't work, everyone thinks they have paid and then a day or so later they receive the message that something went wrong and the payment is paid back to them) and the German version of iDeal has the same issue. 

Link to comment
Share on other sites

  • 2 months later...
On 3/26/2020 at 3:31 AM, Voytek said:

Hello Al, I am also unable to get PayPal working either.  I keep getting this error, is it just broken or am I doing something wrong? 

Error:cURL Error (22): The requested URL returned error: 422 Unprocessable Entity
Response received (422 - Unprocessable Entity)

I have a thread going in the forums related to this. I'm getting the same thing. Did you ever get this sorted out because i'm losing sales now.

Link to comment
Share on other sites

Hello Al,

I am currently having an issue where payment is not being captured yet I have Settlement Mode set to Capture payment immediately. This means no payments are being processed via PayPal.

Also to note the PayPal account has been linked without any issue (that I can see).

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...