Jump to content

PayPal Commerce


CubeCart Bot
 Share

Recommended Posts

12 minutes ago, John at Triton said:

Hello Al,

I am currently having an issue where payment is not being captured yet I have Settlement Mode set to Capture payment immediately. This means no payments are being processed via PayPal.

Also to note the PayPal account has been linked without any issue (that I can see).

 

Having not read the other 3 pages of answers due to time restraints, if you are hosting on your own and not through here, I had this same issue this week. Have your hosting check for a cURL update and make them do it. That's what fixed my issue immediately.

Link to comment
Share on other sites

6 minutes ago, Bad Wolf said:

Having not read the other 3 pages of answers due to time restraints, if you are hosting on your own and not through here, I had this same issue this week. Have your hosting check for a cURL update and make them do it. That's what fixed my issue immediately.

There are plenty of crap hosting companies about.

  • Like 1
Link to comment
Share on other sites

21 minutes ago, Al Brookbanks said:

You shouldn't need to be concerned with requirements. Is there a problem?

Yes the plugin doesn't work. Read through all these pages and it seems it's not uncommon. 

The payment never gets captured and therefore no money moves from my account to the business PayPal account.

Link to comment
Share on other sites

50 minutes ago, Al Brookbanks said:

What do the request logs show? Any red ones (version depending).

using latest version

Today, 12:02
Error:cURL Error (22): The requested URL returned error: 400
Response received (400 - Bad Request)
 
 
Edited by Frank Auffret
Link to comment
Share on other sites

On 1/26/2021 at 11:05 PM, bsmither said:

Just a few seconds before the red error message, is there a related cURL Request in the log that gives details about the order?

 

Sorry for the delay do you mean this?
 

22 Jan 2021, 12:02
Request Sent (cURL) - https://api.paypal.com/v1/oauth2/tokengrant_type=client_credentials
Response received (200 - OK){"scope":"https://uri.paypal.com/services/invoicing https://uri.paypal.com/services/disputes/read-buyer https://uri.paypal.com/services/payments/realtimepayment https://uri.paypal.com/services/disputes/update-seller https://uri.paypal.com/services/payments/payment/authcapture openid https://uri.paypal.com/services/disputes/read-seller https://uri.paypal.com/services/payments/refund https://api.paypal.com/v1/vault/credit-card https://api.paypal.com/v1/payments/.* https://uri.paypal.com/services/payments/initiatepayment https://uri.paypal.com/payments/payouts https://api.paypal.com/v1/vault/credit-card/.* https://uri.paypal.com/services/subscriptions https://uri.paypal.com/services/applications/webhooks","access_token":"A21AAMdHVtpphAlTIYK9JU0XNVfHNaCpVxO55nkDKbTY1I9SN9_zG03ny_8uBhMRWB7z6rl0GGFT-f4XtkZ9rigDxgcShZEpw","token_type":"Bearer","app_id":"APP-28G17306KL4407046","expires_in":32400,"nonce":"2021-01-22T12:02:08ZDVC3OPFxQNQfgZtV2Sg89BBbDHa46BgEppN78d3rz7U"}
22 Jan 2021, 12:02
Error:cURL Error (22): The requested URL returned error: 400
Response received (400 - Bad Request)
Link to comment
Share on other sites

  • 2 weeks later...

I am having problems too with PayPal Commerce Platform - I think it i sonly with apple products(!)

When a customer tries to checkout they just get a blank screen - I think this is apple's equivalent of a 500 error, but it is definitely causing some issues - I have reverted back to the older version of PayPal (PayPal Payments Standard) for now to see if this helps.

Link to comment
Share on other sites

3 hours ago, [email protected] said:

I am having problems too with PayPal Commerce Platform - I think it i sonly with apple products(!)

When a customer tries to checkout they just get a blank screen - I think this is apple's equivalent of a 500 error, but it is definitely causing some issues - I have reverted back to the older version of PayPal (PayPal Payments Standard) for now to see if this helps.

Same here. I've also gone back to PayPal Standard Payment Gateway and are now using Stripe for credit and debit cards as nobody could find the solution (PayPal was saying there is nothing wrong either, but there clearly is) and I was losing customers because of this. 

  • Like 1
Link to comment
Share on other sites

On 3/26/2020 at 6:31 PM, Voytek said:

Hello Al, I am also unable to get PayPal working either.  I keep getting this error, is it just broken or am I doing something wrong? 

Error:cURL Error (22): The requested URL returned error: 422 Unprocessable Entity
Response received (422 - Unprocessable Entity)

Hi Voytek

I have been using Paypal commerce for a while then suddenly having the same errors... and I think a few other errors my end customers have experienced.

Have you resolved this?

Link to comment
Share on other sites

On 2/19/2021 at 3:17 AM, DiMarca Online said:

Same here. I've also gone back to PayPal Standard Payment Gateway and are now using Stripe for credit and debit cards as nobody could find the solution (PayPal was saying there is nothing wrong either, but there clearly is) and I was losing customers because of this. 

Exactly the same issue. I believe it started 2 weeks ago. I noticed my sales dropped down a lot. Good a few customers have called in the last few days. 

Link to comment
Share on other sites

  • 2 months later...

new English / French translation

Show Pay Later messaging [<a href="https://www.paypal.com/webapps/mpp/paypal-payin3" target="_blank">More Info</a>]

Afficher le message Payer plus tard [<a href="https://www.paypal.com/webapps/mpp/paypal-payin3" target="_blank">Plus d'informations</a>]

 

Link to comment
Share on other sites

8 minutes ago, WALMAT said:

Here is to hoping this fixes the gateway issue - So many customers complaining that they pay using paypal and nothing happens - so disappointing.

There are no known issues. Do you have steps to reproduce this?

Link to comment
Share on other sites

  • 2 weeks later...

french traduction : english/french

Pay Later Message - Product Detail Page 

Message Payer plus tard - Page de détail du produit

Pay Later Message - Styling [<a href="https://developer.paypal.com/docs/business/pay-later/us/integrate/customize-messages/" target="_blank">More Info</a>]

Message Payer plus tard - Style [<a href="https://developer.paypal.com/docs/business/pay-later/us/integrate/customize-messages/" target="_blank"> Plus d'informations</a>]

Message text colour

Couleur du texte du message

HTML DOM Location for message

Emplacement du DOM HTML pour le message

JQuery DOM Manuipulator

Manuipulateur DOM JQuery

Basket & Product Detail Page

Panier et page de détail du produit

Message Layout

Disposition des messages

Logo type

Type de logo

Logo position

Position du logo

Message text size

Taille du texte du message

Basket Only

Panier seulement

Product Detail Page Only

Page de détail du produit uniquement

 

 

 

 

Link to comment
Share on other sites

  • 2 weeks later...

Just installed Commerce and it's not working. When you click on the PayPal button then make a payment you return to my site where there's a message saying "Failed to update order. Please try an alternate payment method or contact us for support."

If you try paying through secure checkout then it's possible to eventually make a payment.

I've installed Paypal Standard for now, which works fine.

Any suggestions anyone?

Peter

Link to comment
Share on other sites

On 5/17/2021 at 11:00 AM, PeterJ said:

Just installed Commerce and it's not working. When you click on the PayPal button then make a payment you return to my site where there's a message saying "Failed to update order. Please try an alternate payment method or contact us for support."

If you try paying through secure checkout then it's possible to eventually make a payment.

I've installed Paypal Standard for now, which works fine.

Any suggestions anyone?

Peter

Peter, I have had a customer phone me today - this issue appears to be only with 'Apple' products - so it's back to the old PayPal for me too!

 

On 4/25/2021 at 11:30 AM, Al Brookbanks said:

There are no known issues. Do you have steps to reproduce this?

Appears to be on 'Apple' devices if that helps :-(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...