Jump to content

Australia Post Module


Recommended Posts

I received an email from Australia Post which read:

"Important API Update


Dear API Developer Community,

As part of an update to our infrastructure, we will replace the current SSL Certificate on 10 February 2019 at 13:00 AEDT.

Who will it impact?
Anyone using our Shipping & Tracking, Postage Assessment Calculator, Delivery Choice and all other APIs via auspost.com.au, digitalapi.auspost.com.au or api.auspost.com.au, and has previously manually imported our SSL Certificate into a trusted certificate store.

What should I do?
Consult your developer or plugin provider to see if your application or website is affected. If needed, download and import the new certificate into your trust store.
"

 

It also included a download link for crt files. I was wondering if this updated is required for the Australia Post module to work, if it would have any effect on it at all or if it would continue to work?

Regards, Bruce

 

 

  • Like 1
Link to post
Share on other sites

I'm going to say next week. There I said it.. so lets make it happen. 

OK I just reread your post. I got into a muddle as the Canada Post extension is desperate for an update. They are just updating the SSL certificate. No changes will be necessary in the integration and Aus Post should continue to work as before unless your host takes offence to the new SSL certificate (which is not likely)..

Link to post
Share on other sites
  • 7 months later...

Rather than start a new thread, I'll post my related issue here first in hope of a response.

 I became aware of an issue today which appears to be a problem with the AusPost 1.0.0 shipping Extension, though up until now it has been working great!
A customer contacted us as the shipping option (pulldown) wasn't showing in the basket - the store is tasgingerbread.com
Upon investigating, Dashboard > Manage Extensions > AusPost ... above the "Allowed Zones" tab is a 1 in a red circle.

When I delete the Enabled Regions - Australia (the only region) and save, the red 1 goes away, but the pulldown still doesn't show in the cart.
On adding Aust as the zone again, the red 1 appears again. I have no Disabled Zones set.

I also have the Free Shipping Extension enabled with $30 min purchase and that is working as it should.
I updated to the latest version of CubeCart 6.2.9, that did not resolve the issue.
I have tested going through the checkout to Payment method an it still doesn't show up.
Nothing is showing in the Admin or System Error Logs.
I am using the Kurouto skin if that is relevant.

Thanks in advance for any help :)
Cheers, Tone.

Link to post
Share on other sites

I managed to solve my issue above. I found there was a newer version of the extension, I deleted the old one, updated to V 2.1.1, registered for an AusPost API HERE: https://developers.auspost.com.au/apis/pacpcs-registration and it now works - however, the 1 in a red circle is still above the Allowed Zones tab and I have no idea what it means.

Link to post
Share on other sites

On the Allowed Zones tab, you should see the name of a country in the "Enabled Regions" table for which this module is allowed to only be used. (CubeCart uses "zones" sometimes for the Country, and sometimes for the States/Counties/Provinces of a Country.)

It would be interesting if there is no Country listed in the "Enabled Regions" table, yet there is a count on the Allowed Zones tab.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...