Jump to content
dianepep

Removed skin still showing in Admin Panel

Recommended Posts

I was working on two different skins changing them to different layouts and am now positive which skin I want and which one I do not want and I have removed the unwanted skin via FTP from my website, however, when I go in Admin Panel, Dashboard, Settlings, Default front-end skin is still showing the removed skin as an option. I cannot find where it is getting that from. Can anyone tell me where it is coming from, what I missed and/or how I remove it? Thanks. 

Share this post


Link to post
Share on other sites

The admin Store Settings code asks the function GUI->listSkins() for a list of the skins.

If there is not already a list prepared, that function will scan the /skins/ directory and build a new list. CubeCart then caches that list in the file that has as part of its filename info.skins.list.

If that cached file does exist, the function simply returns the list from that.

Having CubeCart clear its internal cache should also delete that file.

Edited by bsmither

Share this post


Link to post
Share on other sites
On 2/10/2020 at 8:29 PM, bsmither said:

The admin Store Settings code asks the function GUI->listSkins() for a list of the skins.

If there is not already a list prepared, that function will scan the /skins/ directory and build a new list. CubeCart then caches that list in the file that has as part of its filename info.skins.list.

If that cached file does exist, the function simply returns the list from that.

Having CubeCart clear its internal cache should also delete that file.

Thank you for your answer. I did clear the internal cache through the Maintenance tab but it is still showing my deleted foundation as an option to choose. I also copied a new foundation through FTP in my webspace in the skins folder and it is not showing as an option in the Admin Panel. I think I remember when I first copied the Foundation and renamed it that I had trouble getting it to show as an option in the Admin Panel but I forget what I did to correct the situation. It's not harming anything though so it's not a big deal. 

Share this post


Link to post
Share on other sites

In the new skin folder, in addition to renaming the folder's name, you will need to edit the skin's config.xml file, replacing any occurrence of foundation with the new name (except <original name>).

In admin, Store Settings, Advanced tab, find the Enable Caching setting. Next to those words is the method of caching. It will say '(File)', or something. Is it File?

The thing about working in the admin, CubeCart never uses the cache when doing work in there. Are you running CC620 or higher? By not even using the cache when working in the admin, adding and removing skin folders should show instantly on the next page load of Store Settings, Layout tab.

 

Share this post


Link to post
Share on other sites
15 hours ago, bsmither said:

In the new skin folder, in addition to renaming the folder's name, you will need to edit the skin's config.xml file, replacing any occurrence of foundation with the new name (except <original name>).

In admin, Store Settings, Advanced tab, find the Enable Caching setting. Next to those words is the method of caching. It will say '(File)', or something. Is it File?

The thing about working in the admin, CubeCart never uses the cache when doing work in there. Are you running CC620 or higher? By not even using the cache when working in the admin, adding and removing skin folders should show instantly on the next page load of Store Settings, Layout tab.

----------

Ah, I forgot about changing the config.xml file. I copied the foundation that I deleted. That's why it still shows that one and does not show my new one. Thanks again!

I am running 6.25. It says my store is not up to date but I'm afraid to update it because I lost the file where I documented all the changes I made and I made changes to several php files in order to get the store to look how I wanted. So unless there is an important update I prefer to not update it. Would that cause issues?

Maybe i will disable caching while making changes and testing it. Thanks for the suggestion!

 

 

Share this post


Link to post
Share on other sites

Would that cause issues?

If I recall, there are no serious! issues that are fixed between CC625 and CC628. A few issues will likely show themselves if/when you start using PHP7.3.

Share this post


Link to post
Share on other sites
3 hours ago, bsmither said:

Would that cause issues?

If I recall, there are no serious! issues that are fixed between CC625 and CC628. A few issues will likely show themselves if/when you start using PHP7.3.

Okay. Thanks again. Now I only have some small issues to take care of. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...