Jump to content

Getting white screen after 6.2.9 upgrade from 6.2.6


Recommended Posts

Was on php 7.4, tried rolling back to 7.3 but similar issues:

PHP Warning:  Cache data not written (Memcached). in /home/xxxxxx/public_html/tingyen/classes/cache/memcached.class.php on line 255

that section reads:

 //Write to file
        if ($this->_memcached->set($name, $data, (!empty($expire) && is_numeric($expire)) ? $expire : $this->_expire)) {
            return true;
        trigger_error('Cache data not written (Memcached).', E_USER_WARNING);

Any ideas?

Link to comment
Share on other sites

In admin, Store Settings, Advanced tab, "Enable Caching (Type)", what is the type currently saying?

If it is saying 'Memcached', then you might have Memcached available, but unusable.  You may need to switch to 'file'.

This knowledgebase article may help>



Link to comment
Share on other sites

How long has your site been running on PHP 7.3/7.4? That is, did you also upgrade to a later version of PHP when you upgraded to CC6.2.9?

If so, does this new version of PHP have an extension loaded to handle memcache and/or memcached? (Your hosting account's control panel may have a tool to examine which extensions are enabled.)



Link to comment
Share on other sites

Just FYI:

I have just now installed Memcached and the PHP 7.4 extension for it. I also read the KB article on how to force switching to it without re-running setup.

I immediately got an error:

PHP Warning:  ini_set(): Cannot find save handler 'file' in /CubeCart6.4.0/classes/session.class.php on line 100

PHP Warning:  session_start(): open(, O_RDWR) failed: No such file or directory in /CubeCart6.4.0/classes/session.class.php on line 693

PHP Warning:  session_start(): Failed to read session data: files (path: in /CubeCart6.4.0/classes/session.class.php on line 693

I believe this to be due to the fact that I was still logged in when I switched session management mode (thus, current sessions were lost), and also because the information provided in the KB is not 100% correct. See the GitHub issue #2638.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...