Jump to content

6.4.1 - Strange Shopping Cart Behaviour


Dirty Butter
 Share

Recommended Posts

I am in desperate need of help solving this problem.

Please go to https://dirtybutterestates.com and put any item with an image in the shopping cart . The cart pops up as it should. Then click to View Basket. If you are lucky enough, you may see the fleeting view of the Shopping Cart, but it never shows up again. This problem started with the commits right before 6.4.0 betas were released. I assumed it was some code error I had made, since no one else has complained about this happening.

THIS dirtybutterestates.com is totally stock, with Standard PayPal and USPS extensions installed. Stock skin, the works. I installed 6.4.1 over the 6.4.0 I had previously, keeping my own naming system for admin and admin.php.

The only entry in the php error log has to do with an extension I do not have active at this time.

[14-Nov-2020 16:24:32 America/Chicago] PHP Notice:  Error: Hook 'SFWS_Plugin_Updates_Available/hooks/admin.dashboard.tabs.php' was not found in /home/butter01/public_html/dirtybutterestates.com/classes/hookloader.class.php on line 298

There are only Notices in the Admin Error log.

 

 

Link to comment
Share on other sites

I am not noticing anything weird.

When I click View Basket from the Shopping Basket pop-up, I am taken to the View Basket checkout page. I can add more items, the pop-up works, and I can still click the View Basket to get to the "Your Shopping Cart" checkout page.

 

Link to comment
Share on other sites

So do you SEE the cart from the checkout page - a place to choose shipping, add coupon codes, etc., and a payment button?? Could one of you show a screenshot of what the checkout page with basket looks like for you?

Here's what mine looks like:

image.thumb.png.461da3188fa2039fd81143235728350c.png

AH!!! It's FireFox!! Works correctly with Chrome. Any idea what I need to change in settings on FF to fix this?

Link to comment
Share on other sites

I can't see your screenshot - but after your input that it looked right to you, I tested on Chrome. The problem is with FireFox, and I've been going crazy trying to find my mistake with CC!!! UGH!

I don't see anything odd in my FF settings to explain why this does not display for me.

 

Link to comment
Share on other sites

The "Your Shopping Cart" table is enclosed in a <div> block classed for "show-for-medium-up".

From your posted screen grab, it certainly looks like your viewport is wide enough for "medium".

But since these media parameters are based off of the font size, it may be the case where:

* the font (in the browser Options) is very large, but
* the screen magnification is at 50% (for example)

If the above were the case, then a bunch of other things would look "badly sized".

 

Edited by bsmither
Link to comment
Share on other sites

Yes, I have fiddled with the default FF screen size, as I'm having issues seeing some of the smallest print size areas, like the Bookmark sbar . BUT I just did a new install of FF over my old one, instead of the upgrade, and now I DO see the Shopping Cart.

As for SFWS, I quit trying to get the Social MEdia one work. I just post products manually to various media sites.

I should have thought to check browsers a long time ago, but knowing CC was still in commits when this happened I assumed it was my fault or a CC flaw. At least things look right again, and I can think about upgrading our busy shop. Thanks for the help!!

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...