Jump to content

Recommended Posts

Hello,
Some days ago I made upgrade Cubecart from version 6.2.9  to  6.4.2
after upgrade process finished OK, I look message Error 404 page not found when wish look any item from menu or from riight side popular list.
Also if try search items, I got it  and can put in cart.
I tried look where is error but not seen.
Please if anybody has similar experience, help.

Link to post
Share on other sites

If, during the upgrade, you are confident that the database was also upgraded*, then we suggest you clear CubeCart's cache.

* See admin, Maintenance, Upgrade tab, Upgrade History list.

Link to post
Share on other sites
8 hours ago, bsmither said:

If, during the upgrade, you are confident that the database was also upgraded*, then we suggest you clear CubeCart's cache.

* See admin, Maintenance, Upgrade tab, Upgrade History list.

I made clear cashe more times. I can not see nothing useful on Upgrade History list.

Img 4263.jpg

Link to post
Share on other sites

Interesting, if use search, all searched items listed ok. And can add it on the cart, can proceed and make checkout.

Just: 404 - Page not found if wish list items from menu, or select from right side Featured products.

Look like as some folders can not found.

Link to post
Share on other sites

I have notified the CubeCart programmers that CC642 may have significant problems when CubeCart is in a sub-folder.

Please verify that the .htaccess file in CubeCart's folder has this:

### Rewrite rules for SEO functionality ###
<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteBase /cubecart/ 

 

Link to post
Share on other sites

Can not understand, is it bug what manifest in some situation. Is there any programmer who know how system work and understand this problem.

This look like as Cubecart writen by unknown team, and no one responsible, until pay support. Why pay if software has bug. It is just upgrade from lover version to upper. It need be simple and secure.

Img 4268.jpg

Link to post
Share on other sites

Having looked at your .htaccess file, please make this change:

From:

  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^(.*)\.html?$ index.php?seo_path=$1 [L,QSA]

To:

  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^(.*)$ index.php?seo_path=$1 [L,QSA]

Notice the change in the fourth line.

Edited by bsmither
Link to post
Share on other sites
5 hours ago, bsmither said:

RewriteRule ^(.*)$ index.php?seo_path=$1 [L,QSA]

I am having the exact same problem with 404 when I click on any category, page or item.  I tried changing the line in .htaccess but it didn't work.

Any other ideas?

Thanks,

Steve

Link to post
Share on other sites

I solved problem on way, Installed v.6.4.2 on my other (LAN server) and seen system work. After that upload complete CubeCart installation to the cloud server. After that CubeCart start work.

Suppose this is just as a desperate solution, what never should be implemented, but my thin nerves, especially after the terrible 6.3 magnitude earthquake that happened near me.

When I seen in Cubecart property: 9100 files in 690 folders, I agree no one can support that, more complicate than Windows OS.

Link to post
Share on other sites

Very sorry to hear about the earthquake @NebojsaIt makes our installation problems seem very small.

I still have the problem, but it seems that my installation is not reading .htaccess at all on my Windows server.  It seems that it doesn't matter how I change .htaccess, the changes are ignored.  I even changed the 404 error in the code to throw different errors just to see if anything changed, and it didn't.

 

Link to post
Share on other sites

I already note, CubeCart developed as very complex software to hard for maintenance and support. Don't know if existing any debugging methods. With any new version I almost get problems. My CubeCart shop is full simple design, with around 130 items, what I use more to presentation and getting my experience in web shop systems.

I asked myself more times, what problems should be if it real web shop with hundreds daily visitors. It should be terrible. 

With new 6.4.2 version I also discover on my server problems with 'Categories' I adding that, but not appear in menu. Not help Cache clear or similar.

 

Link to post
Share on other sites

CubeCart is not "very complex software" at all (try looking at Magento, OpenCart, Prestashop or most of the other packages) and is much simpler to use from an admin point of view than most.  Is it missing a few things, yes of course but so does every single product out there but @Al Brookbanks does a fantastic job developing and maintaining this.  There are many thousands of sites using it successfully including some with large large turnovers or taking hundreds of orders a day.  The various problems you are having are likely down to how it was installed or upgraded and the hosting environment you are using

19 hours ago, bsmither said:

Having looked at your .htaccess file, please make this change:

@Nebojsa this is a case in point - what Brian has pointed out is something that is clearly shown on the version notes in this forum as a manual change that *may* be needed

 

  • Like 1
Link to post
Share on other sites

 

On 1/5/2021 at 1:43 PM, Nebojsa said:

I asked myself more times, what problems should be if it real web shop with hundreds daily visitors. It should be terrible. 

Sorry, but this does not agree with what you are saying now. CubeCart works well on sites with tens of thousands of visitors a day and many hundreds of orders per day and with proper hosting setup could no doubt deal with more 

11 minutes ago, Nebojsa said:

My opinion related on Cubecart software maintenance and upgrades new features.

As I said, this will simply be down to a lack of knowledge or understanding of what information is where and how to do upgrades. This will come as you get more experience and can be helped by people on this forum 😀

On 1/5/2021 at 1:43 PM, Nebojsa said:

With new 6.4.2 version I also discover on my server problems with 'Categories' I adding that, but not appear in menu.

This is a case in point - this is not a bug but rather the software is working as expected with your configuration - you will have the setting enabled to hide empty categories

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...