Jump to content

PayPal Commerce not working and behaving strangely


Recommended Posts

I have the standard PayPal Commerce installed in my shop.
Ever since, it was shown as a payment option on checkout, but not yet activated.

The entry in "Manage Extensions" just looks like this, no other options:
paypay_button.png.bab0d0188036ca5296b2518c19aed592.png

 

My client opened a PayPay business account and sent me the credentials so I could finish the connection between CC and her PP-account.
I logged in with those and followed the steps. Everything looked normal, no errors, but no link back from the PayPal popup, I could only close it.

Right after that, it is like I never had connected anything. 
The "Sign up or connect your existing account" button is there again and when I click on it, everything starts anew.

If I add a country to "Allowed Zones", it is gone again as soon as I clean the cache, does not let me set it permanently.

But the strangest thing. Ever since it was "successfully connected" (according to PayPal), the payment method no longer shows up in my store.
Before it was there and did not do anything, now it should theoretically work, but does not even show up anymore?

When signed into PP and confirm the connection, I get this popup which I can only close.

paypal1.thumb.jpg.fcaa43c5b4b412fe5436cfa0fe87f780.jpg

 

Shop is almost done from my side, this was very unexpected. I googled it of course and also checked the config-files of this extension. But I don't find anything else to try

Please help!

Link to post
Share on other sites

Up untl today, those were the payment options at checkout:

cc_payment.png.4bc8b55efe489628d205ec4d92683f65.png

 

Now that it should actually work, the option is just gone completely, while still activated in Extensions

cc_payment2.png.b224dbe74849e798b8082585246ee010.png

 

I installed Paypal Standard for a test. It shows in the payment options and seems to actually work without "connecting" or anything.
Why does the "right one" not work and what are possible drawbacks if I use this no longer supported one?

Edited by MostlyConfused
Link to post
Share on other sites

For what it is worth - I still use the Standard, because I want people to create an account on our store. I do not have any issues with 6.4.3. There are other posts here of problems with payment, so I would suggest you search for PayPal and read through some of those threads.

Edited by Dirty Butter
  • Like 1
Link to post
Share on other sites
5 minutes ago, Dirty Butter said:

For what it is worth - I still use the Standard, because I want people to create an account on our store. I do not have any issues with 6.4.3.

Meanwhile I made an actual order and paid with PayPal Standard. Worked perfectly. So as a last resort I could just leave it as is.

But if possible I would rather use an extension that is still considered up to date and supported.

PayPal Commerce seems to generally work, just not for me.
Hope someone helps me find out what's actually wrong with it.

Link to post
Share on other sites
23 hours ago, Tony said:

Admin Console -> Advanced -> Request Log

Anything showing up in red?

Great tip, thank you!
There is something in red, I just don't know what to make of it.

The Situation (again):
- As long as PPC is not connected, it shows up as a payment option at checkout
- When I try to connect, everything looks fine, but as soon as I go back to the basket, PPC as an option is gone. The extension itself looks just like before.
- If I click the button again, the PP-connection process starts new every time with the same result.
- If I cancel this process, PPC payment option is back

And at this moment, when I try to pay with it, I get the following request log.

BUT !!
Of course there would be an error, since PPC is obviously not really connected.
As soon as I try to, the option is gone again and I can't get a request log of it.

Any other ways?

Hre's the log:

requestlog.thumb.png.aec3f01905c70ec80422b4787e6e92f6.png

Edited by MostlyConfused
Link to post
Share on other sites

Officially, according to PayPal - 401 Unauthorised is "This general error relates to an unauthorized request. The request lacked proper authentication and similar errors are often caused by issues related to access tokens."

Have you set up PayPal Commerce with the correct permission in your PayPal account when you linked it with your CubeCart installation?

Link to post
Share on other sites
12 hours ago, Tony said:

Officially, according to PayPal - 401 Unauthorised is "This general error relates to an unauthorized request. The request lacked proper authentication and similar errors are often caused by issues related to access tokens."

Have you set up PayPal Commerce with the correct permission in your PayPal account when you linked it with your CubeCart installation?

Please read my original post again, everything is explained there.
Also my comment directly above yours explains why this error message is not really the problem.

Thanks for any mor ehelp, I really need this.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...