Jump to content

Stripe Session ID missing


Claudia M
 Share

Recommended Posts

I just made my first sale with Stripe after updating to the latest version 3.0.1 ( 3.0.1 - Stripe session ID validation and SDK upgrade to 7.75.0.)

 

Though Stripe showed the payment had cleared, in my admin the order stayed at pending. I manually changed it to processing.

 

The transaction log reads as follows:

Transaction ID             Status Amount           Gateway          Date/Time       Notes

Unknown         Unknown         $29.58             Stripe   Today, 13:07   Stripe session ID missing. Unable to retrieve session data.

Link to comment
Share on other sites

  • Replies 50
  • Created
  • Last Reply

Top Posters In This Topic

Seeing this now with two clients very intermittently - both use Stripe alongside other gateways such as PayPal Standard, POF, PayPal Commerce.  Interestingly a good number of other clients that use Stripe as their sole payment gateway and are using latest 3.0.1, every single payment is going through and updating to processing perfectly

Link to comment
Share on other sites

I'm one of those clients that has it happening. Sometimes there's the message that Claudia also showed ("Stripe session ID missing. Unable to retrieve session data"), but mostly there is nothing, so you don't even know that something is going on.

 

I've been going back and forth with Stripe about this, scaling it up to a specific team (so they claim), but they keep saying it's a CubeCart issue.

 

Thank you for checking into this.

Link to comment
Share on other sites

I don't know if one has to do with the other (probably not ) but I thought I'd throw it out there.  Since I upgraded to CC6.4.2 I get logged out of admin a lot more frequently.  I try to keep it open mostly since I'm usually working on a lot of things.

Link to comment
Share on other sites

20 minutes ago, Al Brookbanks said:

Does anyone have solid steps to reproduce this? 

No, I'm sorry, I don't... 

 

Although maybe Ian can check the SmartLook files, because I just remembered I didn't cancel that one as I said I would LOL

Link to comment
Share on other sites

I had another one today 🤨

The one today was paid by Bancontact (Belgian) and the one yesterday used iDeal (Dutch). Both what I had/have problems with within PayPal Commerce. Maybe there's a connection?

Claudia, was that the case with yours as well?

Link to comment
Share on other sites

4 minutes ago, DiMarca Online said:

I had another one today 🤨

The one today was paid by Bancontact (Belgian) and the one yesterday used iDeal (Dutch). Both what I had/have problems with within PayPal Commerce. Maybe there's a connection?

Claudia, was that the case with yours as well?

Thanks for the payment method isn't relevant as far as I can see. It's the checkout session ID as a whole. I'll get onto this again as soon as I can but I have to prorise my time on the tech support helpdesk.

Link to comment
Share on other sites

29 minutes ago, Al Brookbanks said:

Thanks for the payment method isn't relevant as far as I can see. It's the checkout session ID as a whole. I'll get onto this again as soon as I can but I have to prorise my time on the tech support helpdesk.

Okay thanks, I just thought it was a coincidence (especially since PayPal Commerce gives me trouble as well with those), but I don't want to send you on a wild goose chase 😄

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...