Jump to content

404 errors after upgrade to 6.4.2


augustmoon
 Share

Recommended Posts

I am getting 404 errors when I click on anything, off of the home page, categories, products, even documents, get "Failed to load resource . . ."  In Cubecart  Admin says using PHP version is 7.2.34, but on hosing site says PHP version is 7.3.26, could this be the problem.  Been researching other similar errors on this forum & trying to figure this out for the last week & at loss. When I did update ended up with 2 admin, but made sure /incudes/global.inc.php reflected the new one.  Also when did update doesn't look like all of the folders/files updated to new version - do I need o try to reupdate?  Any insights, much appreciated.  website - shop.augustmoondesign.net

Link to comment
Share on other sites

"Failed to load resource"?

I get CubeCart's custom 404 response.

A very recent version of CubeCart, the Cubecart programmer's accepted the argument that not having a document suffix on the friendly URL (/november-moon instead of /november-moon.html) is better for SEO purposes.

That change requires the .htaccess file be amended. Maybe that happened, maybe not.

Check the contents of the .htaccess file and look for:

RewriteRule ^(.*)?$ index.php?seo_path=$1 [L,QSA]

Note there is no .html in this new version of this rule.

To know the exact nature of what is happening, your browser should have a Developer's Tools feature. In those tools is a Network tab. View the Network table after you ask for a page. It will show what is being requested that is causing this message.

The exact version of PHP 7 does not matter, but the noted discrepancy should cause you to have a conversation with your hosting provider.

It was several versions ago that the CubeCart programmer's decided to offer a bit of 'security by obscurity'. Which is, change the name of the administration folder to something that cannot be guessed.

 

Link to comment
Share on other sites

Thank you so much for responding so quickly. I had looked previously looked for the .htaccess file and even though it said it was there, I could not find it, so I created another in the root directory for the store and it still was not working, then I had one of those "duh" moments after your message & sleeping on it, realized it may be a hidden file.  Sure enough - foundthe file this morning, removed the "/.html", deleted my file & now the website is back up & running like it is supposed to be.  Thank you sooo much!

Link to comment
Share on other sites

So true, so true.  Everything now is pretty much working, but the login/register button in the header.  Tried redirect in  .htaccess file at root - that works for the register, but when click on login, still get a 404  Any ideas?  Here is the code in htaccess file:

<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteRule login{$CONFIG.seo_ext} login.html [R=301,L]
  RewriteBase /
  
  RewriteEngine On
  RewriteRule register{$CONFIG.seo_ext} register.html [R=301,L]
  RewriteBase /
Link to comment
Share on other sites

No.

Remove that.

Your site is using the SFWS Foundation5 Custom skin. It may not have been edited to conform to the new requirements for this .html kerfuffle.

Please examine the template 'box.session.php'. Near the end will be a line of code that may have "login.html" hard-coded.

Compare that with the actual Foundation skin that shipped with CC642.

Link to comment
Share on other sites

Thank you so very much bsmither!  Totally works now, and I can take a breath.

Believe it or not, I was a programmer for over 20 years, but it was either the now ancient language of COBOL or in-house developing.  Have been worked with this in the past, but learn something new every day.

Have a blessed day!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...