Jump to content

404 not found any directory or item


Geotex
 Share

Recommended Posts

Site had a phony .htaccess somehow inserted to redirect. I removed that, restored the original .htaccess, site came up but any front end generates 404 not found.

admin pages working properly, cleared cache, did backups and manually upgraded from 6.42 -> 6.43 -> 6.44. Did not resolve issue. Before updates, checked all files that showed any changes for Aug 6, found nothing out of ordinary. We know the htaccess hack occurred around 4:30 PM CST, from email stamps. All email ceased until I cleared cash this morning, Aug 7 around 11 aM CST.

Current status, admin reporting no issues, tested updates and changes in control panel work fine. All front end links seem show properly in address bar, but generate 404 not found (some other installations I have just show domain/cart/item.html == tried that here, but didn't work, same error)

example menu link

https://littledutchgirl.com/dutch-specialty-foods.html

example featured product link

https://littledutchgirl.com/dutch-specialty-foods/indonesian-conimex/conimex-sambal-badjak-6-oz-jar.html

I searched and found another recent 404 error report seemed a different type of issue, followed the comments. did not resolve my issue.

Any ideas or thoughts much appreciated

Link to comment
Share on other sites

If the skin you are using is not Foundation as shipped with CC640 or later, we may need to make some edits.

Additionally, the .htaccess file has been changed as of CC640.

Make sure the .htaccess file has this exact line:

RewriteRule ^(.*)?$ index.php?seo_path=$1 [L,QSA]

I tried the "dutch-specialty-foods.html" link and got the "Our store is offline" page.

I tried a "dutch-specialty-foods" version of the link, and got the web server's 404 message. So that tells me that the .htaccess file might be using the following statement, which is no longer valid:

RewriteRule ^(.*)\.html?$ index.php?seo_path=$1 [L,QSA]

And, because I got the web server's 404 response, instead of CubeCart's 404 page (or, actually, another "Our store is offline" message), this suggests that the following statements are not present in the .htaccess file:

### Default store 404 page ###
ErrorDocument 404 /index.php

## Override default 404 error document for missing page resources ##
<FilesMatch "\.(gif|jpe?g|png|ico|css|js|svg)$">
  ErrorDocument 404 "<html></html>
</FilesMatch>

 

Link to comment
Share on other sites

Sorry, the store was off line. Back on and WORKING thanks to your advice.

You sent me in the right direction. I went to my demo store that was installed with a late edition. Did a file compare, added the code, Only had to remove RewriteBase directive as this cart is in web root.

Thank you once again for the very valuable help you have provided me when I desperately needed an extra set of really smart eyes.

Can you pm me an email address to deliver a big cup of coffee?

Thanks again, George Snell

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...