Jump to content

Just upgraded to version 6.4.9. Only a few categories will dislplay.


platedepot
 Share

Recommended Posts

I run a site selling used license plates.  I have categories set for all 50 states, Canada and Mexico.  If I select Alabama through Delaware, only the parent category USA Plates displays (with no products).  DC through Kentucky displays fine.  Selecting Louisiana and onward alphabetically (including Canada and Mexico) displays DC through Kentucky in cycles.  Everything looks normal on the back end.

If I select a plate from the Featured Product, it will display normally with the correct category, even if it's not from DC through Kentucky. 

Any help would be appreciated.  My website is www.platedepot.com

Thanks

Mark

 

Link to comment
Share on other sites

Please first check for entries logged in the admin, System Error Log.

Next, enable debug mode (admin, Store Settings, Advanced tab, then enter your local IP address in the next field - www.showmyip.com).

Show the Minnesota category - which will want to show Illinois products. At the bottom of the page, scan through the database queries looking for the one that resembles the following:

SELECT I.product_id FROM `CubeCart_category_index` as I, `CubeCart_inventory` as INV WHERE I.cat_id = 1 AND I.product_id = INV.product_id AND INV.status = 1

where 'I.cat_id = x' will have 'x' equal the actual cat_id of either Minnesota or Illinois.

Link to comment
Share on other sites

Hi bsmither--  Thanks for responding.  I have done as you've recommended and found this.  Category 15 is Illinois.

  • Hack: 1674503255.92020 --- Duration: 1398 µs [NOT CACHED]
  • SELECT I.product_id FROM `CubeCart_category_index` as I, `CubeCart_inventory` as INV WHERE I.cat_id = 15 AND I.product_id = INV.product_id AND INV.status = 1 AND `live_from` < UNIX_TIMESTAMP()

I'm also receive a lot of errors in the error log, which I've attached as a word file here.

 

 

attach.docx

Link to comment
Share on other sites

For future reference, a plain text file is preferred.

So, you were wanting to look at Minnesota? That's what it said in the browser's address bar?

Please make this edit and see if this fixes the situation.

https://github.com/cubecart/v6/issues/3128

 

Edited by bsmither
Link to comment
Share on other sites

That worked perfectly - thank you!

While I have you on the line - I'm still getting about 12 errors per second in the error log.  The first error is always

File: [controller.admin.pre_session.inc.php] Line: [27] "SET @@time_zone = 'UTC'" - Unknown or incorrect time zone: 'UTC'

 

I've tried setting to Pacific Time or UTC -8, but the error always appears with the new time zone substituted for "UTC".  I recall this being an issue in an earlier release.  Is this a quick fix as well?

Thanks!

Mark

Link to comment
Share on other sites

That particular error is a result message from the database server. The database server has a special table that holds all the known timezones.

However, a typical installation of the database server does not include populating this special table with a list of timezones.

The person responsible for managing the database server (usually your hosting provider) is the only person who can get the table populated from this list.

There are other conversations on this forum that discuss it, but ultimately, your hosting provider will need to deal with this. It is not unique to CubeCart.

You can quiet the error notices by making these edits:

/controllers/controller.index.inc.php
/controllers/controller.admin.pre_session.inc.php

Near line 28, find:

$GLOBALS['db']->misc("SET @@time_zone = '".$time_zone."'", false, $debug);

Change to:

// $GLOBALS['db']->misc("SET @@time_zone = '".$time_zone."'", false, $debug);

 

Link to comment
Share on other sites

On 1/23/2023 at 5:27 PM, platedepot said:

I run a site selling used license plates.  I have categories set for all 50 states, Canada and Mexico.  If I select Alabama through Delaware, only the parent category USA Plates displays (with no products).  DC through Kentucky displays fine.  Selecting Louisiana and onward alphabetically (including Canada and Mexico) displays DC through Kentucky in cycles.  Everything looks normal on the back end.

If I select a plate from the Featured Product, it will display normally with the correct category, even if it's not from DC through Kentucky. 

Any help would be appreciated.  My website is www.platedepot.com

Thanks

Mark

 

Also have the same problem - some categories are OK, others completely screwed up. I'll look at the GitHub change and report back.

Link to comment
Share on other sites

On 1/23/2023 at 8:39 PM, bsmither said:
https://github.com/cubecart/v6/issues/3128

I found the right edit (move, not copy) and made the edit. My site works as it should (as far as I can tell) now. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...